New Install of 19.0 Enterprise Error

<oXygen/> general issues.
Jamil
Posts: 77

New Install of 19.0 Enterprise Error

Fri Apr 07, 2017 8:47 am

New install where I selected the option to uninstall version 18.1. This happens during the installation toward the end with the splash screen remaining visible:

Image
adrian
Posts: 2333

Re: New Install of 19.0 Enterprise Error

Fri Apr 07, 2017 11:11 am

HI,

I'm guessing you pressed Finish in the installer with the option to start Oxygen immediately. This dialog belongs to the application, not the installer.

The problem may be specific to your project (.xpr) file. Could you please send us your project (.xpr) file for investigation?
Either send it by email to support@oxygenxml.com or from our Technical Support page.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
Jamil
Posts: 77

Re: New Install of 19.0 Enterprise Error

Sat Apr 08, 2017 9:58 am

It happened for every project file that existed on my laptop after the v19 installation. However, it then no longer appeared the next time I opened the same project files. Whatever the issue was, it seems to have gone away. I am not sure if sending the project files that now no longer have the issue will be so helpful. The project were existing and created with previous versions of the software. Since it happened with several project files, I do not believe that I did anything out of the ordinary in how they were created.

I will see if I can recreate and share more details later.
adrian
Posts: 2333

Re: New Install of 19.0 Enterprise Error

Mon Apr 10, 2017 5:43 pm

Hi,

I've located an unresolved issue on our issue tracking tool with the same symptoms you are describing ("Could not load the project options." warning dialog). For tracking reference it is issue EXM-36614. It has not been resolved yet because we have not been able to reproduce the issue and/or identify the cause.
You see that dialog when starting a new session because Oxygen could not save the project options (just a blank options section) to the project file at the end of the previous session. Unfortunately the dialog is just the symptom of losing the project options in the previous session, so it's difficult to tell what triggered the actual loss in that previous session.
You do not see the dialog a second time for a given project because Oxygen re-writes the options section to the project file. This doesn't change the fact that whatever options were there in a previous session, they got lost (indicated by that warning dialog).

Do you remember any changes you made to the project options or maybe to a transformation scenario saved at project level?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
Jamil
Posts: 77

Re: New Install of 19.0 Enterprise Error

Tue Apr 11, 2017 12:00 pm

Thanks for tracking this issue down.

I do not remember what I may have done with the project files on my laptop (this is where the warning appeared). However, I generally do not do anything out of the ordinary with the software. With every new install, I arrange the toolbars within the editor a specific way. I then generally never have to do this again and will only rearrange them if I see they had returned to default after a new installation. Other than that, my usage is XML, XML schema/validation, and XSLT based primarily.

My laptop is currently the only machine I have that had the older 18.1 version installed prior to the upgrade. My workstation just had a new Windows install, so version 19 is the first install to go onto it.
mandapizz
Posts: 1

Re: New Install of 19.0 Enterprise Error

Wed Nov 15, 2017 10:18 pm

Hello,

I am having this same problem after just installing 19.1. I had 18 before. I don't even use project options, so I'm not sure why this is happening. I've tried closing all files that I have open in Oxygen before closing the program, closing the program, and then opening it again- and I still get this message "Could not load the project options. The file you are loading contains an empty set of options." But I'm not even loading a file, so I don't understand what could be happening to cause this message. Others in my office recently did the install and are not getting this message. I tried uninstalling and then installing again, but no luck- I'm still getting this.
adrian
Posts: 2333

Re: New Install of 19.0 Enterprise Error

Thu Nov 16, 2017 4:19 pm

Hi,

It doesn't matter if you use project options. Due to the issue, the section dedicated to project options is missing from the project (.xpr) file and that's what the message complains about. See this explanation:
Project file broken

"Could not load the project options. The file you are loading contains an empty set of options." But I'm not even loading a file, ...
It refers to the project file which "contains an empty set of options".

Reinstalling won't help because the problem is with the project .xpr file.
Save the project manually with the same name (Project > Save Project As, replace existing file) and the issue should be resolved.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 1 guest