Menu bar lost in High Sierra (Golden Master)

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
mehuneau
Posts: 1

Menu bar lost in High Sierra (Golden Master)

Fri Sep 15, 2017 8:57 pm

If I start Oxygen XML Editor using the script (oxygenMac.sh) then it's okay. But if opened from the app icon (or by double-clicking an XML file), no menu bar.
Radu
Posts: 5093

Re: Menu bar lost in High Sierra (Golden Master)

Mon Sep 18, 2017 3:45 pm

Hi,

Thanks for the feedback.
I will add an internal issue to check this on our side and see if we can do something about this particular problem.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Tue Sep 19, 2017 3:12 pm

Hello,

We have tested, but could not reproduce this issue with Oxygen v19.0, build 2017062918 on macOS 10.13 (High Sierra) 17A362a running on a MacBook Pro 15" (Retina).
What version and build of Oxygen are you running (Help > About)?

Are you running Oxygen in full screen mode or in some peculiar setup (e.g. multiple displays)?
If you have multiple displays, check your other display for the menu.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
sweetpotato
Posts: 5

Re: Menu bar lost in High Sierra (Golden Master)

Wed Sep 27, 2017 2:38 am

I too had the same problem of losing menu bar in High Sierra (version 10.13) as of 27 Sep 2017. This happens on Oxygen Apps ( tried only two Editor or Author) . The other third party apps work OK so far.

My mac is:
MacBook Pro (13-inch, 2017 Four Thunderbolt 3 Ports)
3.1 GHz intel Core i5
16 GB 2133 MHz LPDDR3
Sebra
Posts: 1

Re: Menu bar lost in High Sierra (Golden Master)

Wed Sep 27, 2017 1:00 pm

I faced the same issue. After the update to High Sierra the menu bar has disappeared.
When I start Oxygen - as already mentioned by mehuneau - using the script then it works.

Oxygen v19, build 2017062918
MacBook Pro (Retina 15', Mid 2015
2,5 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel Iris Pro 1536 MB
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Wed Sep 27, 2017 1:33 pm

Hi,

What default language are you using in the macOS System Preferences?
We now know at least of the German language set as default to trigger this issue (we were able reproduce it). This doesn't happen with English.
This seems like an OS bug, as even the system menu of the app is broken. We are still investigating for a proper solution.

Currently the simplest known workaround is to use the oxygenMac.sh script to start the application.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Wed Sep 27, 2017 3:25 pm

Hi,

We have investigated and a possible workaround for this issue is to change a key in the Info.plist file of the .app.
Make sure the .app is closed. Start Finder, go to the Oxygen installation folder (usually in /Applications), Ctrl-click (or right click) on the Oxygen application icon (Oxygen XML Editor.app) and from the pop-up menu select 'Show Package Contents'. Navigate to the 'Contents' directory and edit the 'Info.plist' file. You can open it with 'TextEdit'.
Look for <key>CFBundleAllowMixedLocalizations</key> and change its value from <true/> to <false/>.
Save the changes in the 'Info.plist' file and restart Oxygen.

Note that this is a temporary workaround until Apple fixes this issue. This workaround causes the native user interface (like the app system menu and native Open/Save dialogs) used by the .app to be in English.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
sweetpotato
Posts: 5

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 1:46 am

In my case, the language is Japanese and version of Oxygen Editor is as follows;
Original release date: April 5, 2017
Build id: 2017062918 RSS
Build date: June 29, 2017
Size: 230MB

No multi-displays.
sweetpotato
Posts: 5

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 4:13 am

Huu...m,
I does not seem working in MacOSX in Japanese.

Oxygen Editor:
<key>CFBundleAllowMixedLocalizations</key>
<false/>
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 10:34 am

HI,

Try restarting the OS after making the change to the Info.plist file. It seems it caches the Info.plist if you already started the .app in the current session.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
sweetpotato
Posts: 5

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 10:46 am

Thank you for your prompt response.

I restarted the OS. The result the same - Menu bar remains lost...
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 1:27 pm

Hi,

I tested with Japanese and indeed it seems this workaround doesn't work for this language.
Funny thing is that after testing with Japanese, it doesn't work anymore for the other languages either. English still works, but that does not need this workaround anyway.

We're currently investigating alternate workarounds.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
sweetpotato
Posts: 5

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 2:59 pm

Thanks for your testing.

On High Sierra, the Menu bar is lost in the following apps using Japanese version of MacOS;
1. Oxygen Editor (latest version)
2. iMindMap 10 (latest version)

The other apps the menu bars appear normal and function well on my Mac are;
All the rest including,
1. FilemakerPro Advanced 16 (latest version)
2. BBedit (latest version)
3. Merlin Project (latest version)
4. Apps of Omni Group (Graffle, Plan, Focus, Outliner) (latest version)
5. R and R studio (latest version)
6. Final Cut Pro (latest version)
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 3:19 pm

Hi,

AFAIK, only Java applications are affected by this issue.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Thu Sep 28, 2017 6:20 pm

Hi,

Later Edit: This problem has been fixed in macOS 10.13.1. You should update the OS to resolve the issue, rather than use the workaround.

I have a simpler workaround that works for all languages.
Open a Terminal window and execute the following command.
For Oxygen XML Editor use:

Code: Select all

defaults write ro.sync.exml.Oxygen AppleLanguages '(en)'

For Oxygen XML Author use:

Code: Select all

defaults write ro.sync.exml.Author AppleLanguages '(en)'

For Oxygen XML Developer use:

Code: Select all

defaults write ro.sync.exml.Developer AppleLanguages '(en)'

For Diff Directories use:

Code: Select all

defaults write ro.sync.exml.DiffDirs AppleLanguages '(en)'

For Diff Files use:

Code: Select all

defaults write ro.sync.exml.DiffFiles AppleLanguages '(en)'

For Syncro SVN Client use:

Code: Select all

defaults write ro.sync.SyncroSVNClient AppleLanguages '(en)'

This sets the language to English for the respective app and thus the Java menu bar is correctly displayed.

Note that this does not affect the language you use in the Oxygen UI. That can still be set in Options > Preferences, Global, Language.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
rn2ee
Posts: 1

Re: Menu bar lost in High Sierra (Golden Master)

Tue Oct 03, 2017 12:29 pm

Workaround from Adrian works for me, all menus are back in German language...
fmarek
Posts: 1

Re: Menu bar lost in High Sierra (Golden Master)

Wed Oct 04, 2017 12:58 pm

Workaround from Adrian works for me, all menus are back. Thanks a lot.
adrian
Posts: 2326

Re: Menu bar lost in High Sierra (Golden Master)

Mon Nov 13, 2017 3:50 pm

Hi,

The latest build of Oxygen 19.1 includes an out-of-the-box solution for the 10.13 issue.
This problem has also been fixed in macOS 10.13.1. You should update the OS to resolve the issue, rather than use the workaround.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest