Product attribute in related-links excluding links from output?

ren
Posts: 5

Product attribute in related-links excluding links from output?

Mon Aug 28, 2017 6:26 pm

Hello

We've inserted product attribute tags into related-links for our in-context help output. The .ditaval value is set to 'include' for these attributes.

However, once we build the output, the related links that have product attributes applied are removed from the output and only the links without attributes applied display.

Ditaval:

Code: Select all

 <prop att="product" val="example_attribute" action="include"/>

.xml file:

Code: Select all

  <related-links>
    <link href="../example_included_link/example_included.xml#included"/>
    <link
      href="../example_excluded_link/example_excluded.xml#excluded" product="example_attribute"
    />
  </related-links>

Previously, having both a product and platform attribute excluded the link from displaying, despite both values being set to 'include' in the ditaval. When I removed the platform attribute, the link displayed in the output with the product attribute applied. Now the link will only display in the output if all attributes are removed. This is problematic as we rely on product attributes to selectively include/exclude content by product offering.

Do you have any ideas as to why the ditaval value isn't being respected?
Thanks
Ren
radu_pisoi
Posts: 327
Location: Craiova

Re: Product attribute in related-links excluding links from output?

Tue Aug 29, 2017 4:04 pm

Hi,

Thank you for contacting us.

We are not aware of a such issue. I have tested with DITA-OT 2.4.4 that comes bundled with oXygen 19.0. I don't see any problem related to the DITA val filtering in the WebHelp Responsive output.

Could you provide us more information?
- What version of oXygen and DITA-OT are you using?
- What output type are you using? WebHelp, PDF?
- Could you send us at support@oxygenxml.com a small DITA map with the referenced topics to reproduce the problem?
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
ren
Posts: 5

Re: Product attribute in related-links excluding links from output?

Thu Aug 31, 2017 5:45 pm

Hi Radu

We are using oXygen XML Author v.18.0, build 216062718
DITA-OT 7.8
The output type is webhelp responsive

Due to customer confidentiality, I will verify whether I am permitted to send a sample project.

To clarify, the only issue is with ditaval filtering in related links, so in the <link href="<link file path>" product="x"/>. At the topic and in-text level (say in paragraph elements), the filtering works as expected.
ren
Posts: 5

Re: Product attribute in related-links excluding links from output?

Thu Aug 31, 2017 5:54 pm

To update, now any content tagged with an attribute is not displaying in oxygen or in the output, regardless of the ditaval settings. We have had this issue with our PDF output and found deleting the transformation scenario and recreating it was helpful. In the case of the Webhelp Responsive, this is not affecting the issue.
Radu
Posts: 5585

Re: Product attribute in related-links excluding links from output?

Mon Sep 04, 2017 9:24 am

Hi,

To update, now any content tagged with an attribute is not displaying in oxygen or in the output, regardless of the ditaval settings.


I'm not sure I understand anymore. I thought this issue was related to the webhelp output.
When you have a topic opened in Oxygen in the Author visual editing mode, on the toolbar there is a funnel-shaped drop-down action which allows you to select the current applied condition set and also to set the "Show Excluded Content" checkbox if you want Oxygen to visually hide content which does not match the current applied condition set.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 4 guests