URL displayed instead of link text

pault
Posts: 55

URL displayed instead of link text

Thu Aug 10, 2017 6:31 am

In some of the HTML generated by WebHelp Responsive Mac (XML Editor 19.0, build 2017062918), the URL is displayed instead of the generated text. For example:

Code: Select all

<xref keyref="multiDCperWorkloadType"/>

is rendered in the HTML as

Code: Select all

 ../production/multiDCperWorkloadType.html

instead of the title text "Initializing multiple datacenters per workload"

This doesn't occur everywhere, only in some places and I although I've compared the ditamaps, reference files, etc, and tried a number of things, I cannot solve the problem or find any differences.

Do you have any suggestions about what to look for?
Radu
Posts: 5217

Re: URL displayed instead of link text

Thu Aug 10, 2017 8:07 am

Hi Paul,

Are you using DITA OT 1.8 or 2.x for publishing? The Oxygen Preferences->DITA page should show the default used DITA OT version. Or are you using your own DITA Open Toolkit installation located outside of Oxygen?
Do you have in your DITA project references to resources outside of the folder where the main DITA Map is located? If so, maybe you can try suggestion (2) from here:

https://www.oxygenxml.com/doc/versions/19.0/ug-editor/topics/dita-ot-external-refs.html

Otherwise if you manage to put together a sample project exhibiting the problem you can use our online feedback form to send it to us:

https://www.oxygenxml.com/techSupport.html

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
pault
Posts: 55

Re: URL displayed instead of link text

Thu Aug 10, 2017 8:36 pm

Hi Radu,

So problem resulted from a keyref inside a note in a different file, not the one where the problem showed up but within the same ditamap:

Code: Select all

<note id="kmip_cmds">The dsetool <xref keyref="dsetool/managekmip"/>  command proxies KMIP commands ...

Here's what cross reference linked to:

Code: Select all

<plentry id="managekmip">
     <pt>managekmip (help|list|expirekey|revoke|destroy) <varname>kmip_group_name</varname [<varname>command_arguments</varname>]</pt>


Removing the <varname> tags fixed the problem. It appears than any link to an element with "inside" tags is not permitted or is this a bug?
Radu
Posts: 5217

Re: URL displayed instead of link text

Fri Aug 11, 2017 10:46 am

Hi,

This looks like a DITA Open Toolkit bug. I tested with the DITA OT 1.8 bundled with Oxygen and it properly works.
But the DITA OT 2.4.4 bundled with Oxygen 19.0 indeed seems to have this problem.
After this I downloaded the latest DITA OT 2.5.2, tested the same situation with it and the situation seems to be fixed.
So maybe you can try to download separately DITA OT 2.5.2:

http://www.dita-ot.org/download

integrate the Oxygen WebHelp plugin in it:

https://www.oxygenxml.com/doc/versions/19.0/ug-editor/topics/integrating-webhelp-plugin-with-dita-ot.html

and afterwards in the Oxygen Preferences->DITA page set that external newer DITA OT to be the default used one.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
pault
Posts: 55

Re: URL displayed instead of link text

Fri Aug 11, 2017 10:02 pm

Thanks Radu!

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 2 guests