Prints empty page in Webhelp in Internet Explorer

rnvrnv
Posts: 17

Prints empty page in Webhelp in Internet Explorer

Mon Jul 10, 2017 11:19 am

hi all,

when I publish webhelp and use Print feature in Internet Explorer it is empty. Chrome seems to be fine. what could be wrong?

I have IE version 11.0.9600.18697.

thank you in advance,
rnv
bogdan_cercelaru
Posts: 202

Re: Prints empty page in Webhelp in Internet Explorer

Wed Jul 12, 2017 3:50 pm

Hello,

Thank you for reporting this.
I've just tested with latest version of Oxygen v19.0 and the built-in DITA Map WebHelp Classic transformation scenario. I can confirm that when you try to print a page from Internet Explorer 11 the page is empty.
I've registered in issue in our internal bug tracking system to be addressed.
In the meantime, to solve this issue you should open the "DIA_OT_DIR/plugins/com.oxygenxml.webhelp/oxygen-webhelp/resources/skins/desktop/toc_driver.js" file and replace the following function:

Code: Select all

function printFrame(id) {
    var frm = document.getElementById(id).contentWindow;
    frm.focus();// focus on contentWindow is needed on some ie versions
    frm.print();
    return false;
}

with the following one:

Code: Select all

function printFrame(id) {
    var frm = document.getElementById(id).contentWindow;
    frm.print();

    return false;
}

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
rnvrnv
Posts: 17

Re: Prints empty page in Webhelp in Internet Explorer

Thu Jul 13, 2017 3:10 pm

Thank you for your response,

please note that I found this windows issue, maybe it is related:

https://answers.microsoft.com/en-us/ie/ ... d9ae23a477

regards,
rnv

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest