Unresolved and empty conkeyrefs.

Posts: 1

Unresolved and empty conkeyrefs.

Fri May 12, 2017 5:17 pm

We're currently working on a ditamap where we have two topics where we are trying to use conkeyrefs. Both files have conkeyrefs in the title and in tags inside the body, such as a <p> and a <section>.

I worked through the pipeline backwards and found by the time we get to the mappullImpl.xsl (when we first get an error on the output) the file is already missing all tags with conkeyrefs. The entire tag, and the content, are gone. Since the topic titles have conkeyrefs, we get errors in the ToC entries.

We've updated to the latest dita-ot we could find (DITA-OT version = 2.4.6+b074a2c) but still can't get conkeyref to work. We're using OxygenXML 19.0 and the editor resolves all conkeyrefs perfectly (in Author mode the editor displays the correct fetched text) and gives no errors or warnings.

I tried to look through dita-ot for references to @conkeyref that might help figure out where I need to debug and figure out what is wrong. Can't find anything. I find a lot of stuff for keyrefs, but nothing for conkeyrefs. Can't figure out where they're processed.

So basically... as anyone had a similar problem? Or can someone point me to where I should start looking, please?

Thank you.
Posts: 5921

Re: Unresolved and empty conkeyrefs.

Mon May 15, 2017 12:42 pm


I see that you added an issue here:


I will try to give you feedback on that issue in order to avoid duplicate posts.

Radu Coravu
<oXygen/> XML Editor

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: ionela and 1 guest