WebHelp Responsive: Shared topics not linked correctly

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
B-E-N
Posts: 111

WebHelp Responsive: Shared topics not linked correctly

Mon Dec 19, 2016 4:12 pm

Hello,

there is a bug in the WebHelp Responsive output in Oxygen Editor 18.1 (build 2016112217).

I have a ditamap that contains several sub-ditamaps. And I have a topic that must appear at two different locations in the operation manual. So the same topic is linked in sub_ditamap_a and sub_ditamap_b.

When I now click on the topic title of the shared topic in the table of content of ditamap_b, the topic is always opened in ditamap_a. The URL displays the link to ditamap_a and the TOC of ditamap_a is opened.

I have also activated the previous/next navigation buttons. There is also a bug. For shared topics, several previous/next arrows are displayed. One for each location of this topic at any position in the ditamap.
B-E-N
Posts: 111

Re: WebHelp Responsive: Shared topics not linked correctly

Fri Mar 24, 2017 3:53 pm

Is there a fix in sight for this? Some topics in our WebHelp look very weird because of it. It makes navigation past those shared topics very difficult.

Image
radu_pisoi
Posts: 328
Location: Craiova

Re: WebHelp Responsive: Shared topics not linked correctly

Fri Mar 24, 2017 5:32 pm

Hi,

Sorry for the late reply. It was a problem in our internal management system for users feedback and the this message was somehow omitted.

For the case when you want to refer the same topic in the DITA map for multiple times, it is recommended to use the copy-to attribute like in the following sample:

Code: Select all

<topicref href="tasks/gardenPreparation.dita" copy-to="tasks/gardenPreparation-copy.dita"/>

https://www.oxygenxml.com/dita/1.3/spec ... butes.html

In case when you use the copy-to attribute, a separate HTML file will be generated into the output folder, so the navigational links(breadcrumb, side TOC, menu) from WebHelp output could be computed correctly.
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
B-E-N
Posts: 111

Re: WebHelp Responsive: Shared topics not linked correctly

Fri Mar 24, 2017 5:47 pm

Great, I wasn't aware of that attribute. Thanks, it works.

Return to “Common Problems”

Who is online

Users browsing this forum: shudson310 and 0 guests