Issues when upgrading to SDK 18.1.0.0

Post here questions and problems related to oXygen frameworks/document types.
Johann
Posts: 95
Joined: Wed Jun 17, 2015 12:46 pm

Issues when upgrading to SDK 18.1.0.0

Post by Johann » Mon Jan 30, 2017 8:01 pm

Hello everyone,

I upgraded the oxygen SDK from 18.0.0.3 to 18.1.0.0.

When I try to call this method :

Code: Select all

(AuthorComponentProvider) factory.createEditorComponentProvider(editors, EditorPageConstants.PAGE_TEXT);
I got this error :

Code: Select all

java.lang.NoClassDefFoundError: com/google/common/cache/CacheBuilder
at ro.sync.azcheck.ui.spellcontrol.hunspell.d$_c.<init>(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
at ro.sync.azcheck.ui.spellcontrol.hunspell.d.n(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
at ro.sync.azcheck.ui.spellcontrol.hunspell.f$_b.<init>(Unknown Source) [oxygen-18.1.0.0.jar:na]
at ro.sync.azcheck.ui.spellcontrol.hunspell.f.ib(Unknown Source) [oxygen-18.1.0.0.jar:na]
at ro.sync.azcheck.ui.spellcontrol.f.q(Unknown Source) [oxygen-18.1.0.0.jar:na]

I added this dependency in my project :

Code: Select all

        <dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>19.0</version>
</dependency>
This error seems to disappear... Is it normal I had to add this dependency ?
Then, when I call the method load of the ro.sync.ecss.extensions.api.component.AuthorComponentProvider class, I get this error (the component is not created) :

Code: Select all

java.lang.ClassNotFoundException: org.w3c.flute.css.sac.ConditionFactory
at ro.sync.ecss.component.o.xyh(Unknown Source)
at ro.sync.exml.editor.xmleditor.pageauthor.g.aci(Unknown Source)
at ro.sync.exml.editor.k.drh(Unknown Source)
I do not find the dependency to add in order to resolve this issue. Can you help me on this issue ?

Thanks in advance,

Johann

alex_jitianu
Posts: 779
Joined: Wed Nov 16, 2005 11:11 am

Re: Issues when upgrading to SDK 18.1.0.0

Post by alex_jitianu » Tue Jan 31, 2017 12:10 pm

Hi Johann,
This error seems to disappear... Is it normal I had to add this dependency ?
In version 18.1 we added a dependency for "com.google.guava". If your POM file declares a dependency on our SDK, then all these additional dependencies would be picked up automatically:

Code: Select all

<dependency>
<groupId>com.oxygenxml</groupId>
<artifactId>oxygen-sdk</artifactId>
<version>18.1.0.0</version>
</dependency>
I do not find the dependency to add in order to resolve this issue. Can you help me on this issue ?
The above dependency should fix this second exception too. But, if you prefer to specifically refer a subset of JARs, then a dependecy like this one should fix it:

Code: Select all

<dependency>
<groupId>com.oxygenxml</groupId>
<artifactId>oxygen-css-flute-parser</artifactId>
<version>18.1.0.0</version>
</dependency>
Best regards,
Alex

Post Reply