CALS table formatting error - changes from multiple columns to one

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
akmenting
Posts: 12

CALS table formatting error - changes from multiple columns to one

Tue Nov 01, 2016 7:22 pm

I was working with an existing CALS table, inserted a column and rows, and then added all entries. The table formatting was fine, but after checking in and out of the content management system, the table formatting changed from 3 columns to one, and repeats the first row for each cell. The first row includes an entry with an ul. Other tables with ul entries are fine within the topic.
In the problem table, the tgroup element is underlined, each row begins with LI__x and a link to an entry in DITA.

Help?
Radu
Posts: 5585

Re: CALS table formatting error - changes from multiple columns to one

Wed Nov 02, 2016 3:22 pm

Hi,

What CMS are you using? This looks like a problem in how the CMS is storing the XML. Maybe you should try to contact them instead.
I remember the Astoria CMS sometimes added in the XML content elements like LI__x but I'm not sure why it does that, if you want I could try to get somebody from their side to respond on the forum...

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
akmenting
Posts: 12

Re: CALS table formatting error - changes from multiple columns to one

Fri Dec 09, 2016 10:08 pm

Thank you, it was the CMS.
Dan_K
Posts: 4

Re: CALS table formatting error - changes from multiple columns to one

Wed Jan 04, 2017 8:41 pm

Hello.
I am experiencing the same problem but I dont have a CMS content manager system.
I want to create a CALS-Table with several columns and rows, but until now without success.
I am using oXygen 18.1 and the PI-Mod.dtd v1.0, as well as the CSS that comes along with the download package.
Where is my mistake, can someone help me out?

In Autormodus, it looks like this:
[colspec][colspec][colspec]
[Header1]
[Header2]
[Header3]
1
2
3
4

Code: Select all

<table
                    frame="all"  tablewidth="fullpage" colsep="1" rowsep="yes">
                   
                    <tgroup cols="3" colsep="1">
                        <colspec colname="c1" colnum="1" colwidth="50pt" rowsep="1" colsep="1"/>
                        <colspec colname="c2" colnum="2" colwidth="60 pt"/>
                        <colspec colname="c3" colnum="3" colwidth="80pt" colsep="yes"/>
                        <thead>
                            <row rowsep="1">
                                <entry rowsep="1" colsep="yes ">Header1</entry>
                                <entry rowsep="1" colsep="1">Header2 </entry>
                            </row>
                            <row>
                                <entry>Header 3</entry>
                            </row>
                        </thead>
                       
                        <tbody>
                            <row rowsep="1">
                                <entry colsep="1">1</entry>
                                <entry rowsep="1">2</entry>
                            </row>
                           
                            <row>
                                <entry colsep="1">3</entry>
                                <entry>4</entry>
                            </row>
                           
                        </tbody>
                    </tgroup>
                </table>
Radu
Posts: 5585

Re: CALS table formatting error - changes from multiple columns to one

Thu Jan 05, 2017 9:24 am

Hi Denny,

Oxygen does not out of the box support for PI-MOD and we are not very familiar with it but the table looks like a standard CALS table and if the CSS is properly written Oxygen should be able to properly display the table. Is there an Oxygen-specific framework for editing PI-MOD, if so, is it publicly accessible?
So what is the exact problem that you are encountering? I see that you have a table cell called <entry>Header 3</entry> but you have placed it in a separate row, did you want to place the entry in the first heading row instead of placing it on a separate row?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Dan_K
Posts: 4

Re: CALS table formatting error - changes from multiple columns to one

Thu Jan 05, 2017 7:13 pm

Thanks for the quick reply.
I think managed to solve the problem. After alternating the CSS, the CALS-table behaved the way it should when I tested it with the Firefox browser.

In PI-Mod Standard CSS, I had to change a few of the CALS-table-child-Elements formating from

Code: Select all

display: block
to

Code: Select all

display: flex-inline
.

But still, in Authoring Mode of the oXygen XML-Editor, all the cells still appears in one column on top of each other. The Internet browser however, shows several colums and rows like it should. For now, it does the job, although it is irratating and uncomfortable.

Thanks for the way-pointer.

Sincerly, D.
Radu
Posts: 5585

Re: CALS table formatting error - changes from multiple columns to one

Fri Jan 06, 2017 9:50 am

Hi Dan,

The Oxygen Author visual CSS-based editing does not have support for flexbox. Based on your feedback I will add an issue for this but I cannot give you a timeline. Our CSS-based rendering engine will never be as evolved as a web-browser's.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 1 guest