Problems with two DITAmaps open

cjboorman
Posts: 37
Joined: Wed Jun 19, 2013 1:49 am

Problems with two DITAmaps open

Post by cjboorman » Tue Nov 01, 2016 10:45 pm

I noticed a problem with one of my parent topics. It was showing four subtopics in the table of contents, but in the content pane, it showed ten topics. I know that this happens when you reuse a topic within the same ditamap, but I hadn't reused this topic in my ditamap. I checked the Oxygen UI, and I noticed that I had two ditamaps open, so I closed one of them and then I regenerated the docs - and the problem went away. It seems Oxygen detected that this topic was used twice, so it combined the child topics and presented them in the list of links in the topic.

Is this a bug, or a feature? :shock:


Thanks,

Chris Boorman.

Radu
Posts: 6138
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problems with two DITAmaps open

Post by Radu » Wed Nov 02, 2016 12:56 pm

Hi Chris,

I'm sorry but I do not understand, maybe you could send us some screenshots + more details using our email address (support@oxygenxml.com).
The publishing process should not depend at all on how many DITA Maps are opened in Oxygen, it only depends on the DITA Map which gets published. Maybe one possibility would be that the output folder was not deleted between various publishing tasks and it accumulated files from previous publishing tasks. You can manually remove the output folder before publishing to test this.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply