Webhelp navigation pane repeating in content area

<oXygen/> general issues.
kmank
Posts: 108
Joined: Mon Apr 19, 2010 5:33 pm

Webhelp navigation pane repeating in content area

Post by kmank » Wed Apr 06, 2016 5:12 pm

When I transform webhelp, the navigation (TOC) pane repeats itself unendingly in the Content pane.
Image

Any ideas what could be the cause?

kmank
Posts: 108
Joined: Mon Apr 19, 2010 5:33 pm

Re: Webhelp navigation pane repeating in content area

Post by kmank » Wed Apr 06, 2016 5:15 pm

I should state that if I access the same DITA-OT, skin, and same exact files through a virtual machine, the transform works as it should. Only when I try to transform natively does it produce the error.

bogdan_cercelaru
Posts: 221
Joined: Tue Jul 01, 2014 11:48 am

Re: Webhelp navigation pane repeating in content area

Post by bogdan_cercelaru » Thu Apr 07, 2016 11:19 am

Hello,

Is the output from your computer the same with the one from the virtual machine? You can use the Diff Directories to check this.
If it is possible, please archive both outputs and send them to us at support@oxygenxml.com to be analyzed.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

kmank
Posts: 108
Joined: Mon Apr 19, 2010 5:33 pm

Re: Webhelp navigation pane repeating in content area

Post by kmank » Thu Apr 07, 2016 4:48 pm

Well, that appears to be the issue.
The offending output was C:/out/${pn}/${date(yyyy-MM-dd)}/webhelp - it tried to include the project name (there is none for this instance). When I modified that to read C:/out/${cfne}/${date(yyyy-MM-dd)}/webhelp, to include the ditamap filename in place of the project name, the transform worked perfect.

Thanks for the pointer.

Post Reply