oXygen deletes my framework-files

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
stdu
Posts: 81
Joined: Mon Mar 05, 2012 5:23 pm

oXygen deletes my framework-files

Post by stdu » Tue Mar 01, 2016 12:05 pm

Since a while I encouter a strange problem: I develop three oXygen frameworks:

1) Framework
2) Extension-Framework which extends Framework 1
3) Another framework

And while I'm working on a framework, oXygen deletes sometimes (i.e. one time per working session) the framework file (i.e. xyz.framework, no other files are affected)! If oXygen is still running I can save it again, if I close oXygen without controlling if the file is still there, the framework is lost (unless I've made a backup or have an older version).

Normally during my development I've opened both - oXygen Editor and oXygen Author. It seems, that oXygen is deleting my file while I do changes in a framework via the Configurations Menus in Author (it happened in all three frameworks).

My system: Win 7 Professional, SP 1, 64bit / Java (32bit) 1.8.0_71/ XML Editor 17.1, build 2015121117

Can anybody help?

Thx & kind regards,
Stefan

Radu
Posts: 6541
Joined: Fri Jul 09, 2004 5:18 pm

Re: oXygen deletes my framework-files

Post by Radu » Tue Mar 01, 2016 12:17 pm

Hi Stefan,

We recently identified and fixed an issue in which when somebody edited a framework configuration and then in the Preferences dialog clicked "Apply" and then quickly clicked "OK" some of the frameworks got deleted. Would you consider this to be related with what you are experiencing?
Also you mentioned you are opening both XML Editor and XML Author simultaneously. If they are opened from the same installed location or if you have configured them to use the same frameworks folder it's a possibility that one of them will save over the other. So you should avoid having both applications opened at the same time.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

stdu
Posts: 81
Joined: Mon Mar 05, 2012 5:23 pm

Re: oXygen deletes my framework-files

Post by stdu » Tue Mar 01, 2016 12:42 pm

We recently identified and fixed an issue in which when somebody edited a framework configuration and then in the Preferences dialog clicked "Apply" and then quickly clicked "OK" some of the frameworks got deleted. Would you consider this to be related with what you are experiencing?
Ah, yes, that could be the issue! As I wrote my post, I noted that I didn't yet installed the recent version of oXygen. Is this issue already fixed in the last recent build?

My author and editor use both the same framework location, but I usually configurate frameworks only in author - in the editor I edit only CSS, schema files etc.

Regards,
Stefan

Radu
Posts: 6541
Joined: Fri Jul 09, 2004 5:18 pm

Re: oXygen deletes my framework-files

Post by Radu » Tue Mar 01, 2016 12:44 pm

Hi Stefan,

The fix will be available in Oxygen 18, we have not made it available for Oxygen 17.1.
Just to try and avoid this situation, if you press Apply you should let a couple of seconds pass before pressing OK. Or you can press OK directly in the dialog without pressing Apply first.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

stdu
Posts: 81
Joined: Mon Mar 05, 2012 5:23 pm

Re: oXygen deletes my framework-files

Post by stdu » Tue Mar 01, 2016 1:13 pm

Okay, this should work, thanks!

Post Reply