Java spell checker seems to be not working

<oXygen/> general issues.
tmakita
Posts: 69

Java spell checker seems to be not working

Fri Jul 31, 2015 4:57 pm

Hi Support team,

One of our user uses English word in Japanese authoring. If Hunspell Spell Checker is enabled, all of the Japanese characters were assumed as spelling error. So I tested switching to Java Spell Checker. The Japanese character errors were fixed. But English word spelling error seems to be not checked.

Are there any solutions for this problem? Or are there any problems in my oXygen (17.0) setting?

I uploaded following three files to the drop box:

Preference setting dialog image:
https://www.dropbox.com/s/sfemih1u7md5euz/jsc.png?dl=0

Editing window snap shot:
https://www.dropbox.com/s/2aiij3rzyyy3z ... r.png?dl=0

Sample data (Please change public identifiers and keyref attribute):
https://www.dropbox.com/s/9pr3sc8diikrj ... 8.xml?dl=0

Regards,

--
/*--------------------------------------------------
Toshihiko Makita
Development Group. Antenna House, Inc. Ina Branch
E-Mail tmakita@antenna.co.jp
8077-1 Horikita Minamiminowa Vil. Kamiina Co.
Nagano Pref. 399-4511 Japan
Tel +81-265-76-9300 Fax +81-265-78-1668
Web site:
http://www.antenna.co.jp/
http://www.antennahouse.com/
--------------------------------------------------*/
--
/*--------------------------------------------------
Toshihiko Makita
Development Group. Antenna House, Inc. Ina Branch
Web site:
http://www.antenna.co.jp/
http://www.antennahouse.com/
--------------------------------------------------*/
adrian
Posts: 2337

Re: Java spell checker seems to be not working

Fri Jul 31, 2015 7:49 pm

Hello,

You seem to have no Default language selected after switching to the Java spell checker. That's most likely the reason it doesn't work at all. Please pick a default language.
Note that the Java spell checker uses a different set of dictionaries than Hunspell. I must also mention that the Java spell checker is obsolete and it's unlikely that it would work any better than Hunspell.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
tmakita
Posts: 69

Re: Java spell checker seems to be not working

Sat Aug 01, 2015 3:50 pm

Hi Adrian,

Thank you for your reply.

You seem to have no Default language selected after switching to the Java spell checker. That's most likely the reason it doesn't work at all.


Yes, but in some cases the candidates for the default language of Java spell checker does not appear in combo-box. Please see following dialog snap shot:

https://www.dropbox.com/s/ocb819x3sbjoe ... r.png?dl=0

For your reference if I change spell checker from Hunspell to Java in another project, it works fine because I can set default language to English.

I think there are no dictionary problems in my oXygen installation. Following is the my dict/spell folder contents.

https://www.dropbox.com/s/njpuy0xb6vm89 ... r.png?dl=0

Are there any my mis-operation in switching spell checker?

Regards,
--
/*--------------------------------------------------
Toshihiko Makita
Development Group. Antenna House, Inc. Ina Branch
Web site:
http://www.antenna.co.jp/
http://www.antennahouse.com/
--------------------------------------------------*/
adrian
Posts: 2337

Re: Java spell checker seems to be not working

Tue Aug 04, 2015 5:45 pm

Hello,

I don't reproduce the exact problem (empty "Default language" combo box), but I could reproduce a bug when setting the "Spell checking engine" to "Java spell checker" in "Project Options". When switching between projects, the "Default language" combo would sometimes list the supported languages (they are actually dictionaries) of Hunspell instead of the ones that belong to the "Java spell checker". I've logged this bug on our issue tracking tool to be investigated and resolved.

If you switch the engine to "Hunspell" and back to "Java spell checker", is the "Default language" combo updated accordingly?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
tmakita
Posts: 69

Re: Java spell checker seems to be not working

Thu Aug 06, 2015 3:40 pm

Hi Adrian,

Thank you for your investigation.

If you switch the engine to "Hunspell" and back to "Java spell checker", is the "Default language" combo updated accordingly?


NO, in my PC environment the phenomenons are following in both Global Options and Project Options:

1. When switching from "Hunspell" to "Java spell checker" the "Default language" combo became empty.
2. When switching from "Java spell checker" to "Hunspell" the "Default language" combo became normal and display the candidates.

My PC: Windows 8.1 64bit oXygen XML Editor 17.0

I hope this helps your investigation.

Regards,
--
/*--------------------------------------------------
Toshihiko Makita
Development Group. Antenna House, Inc. Ina Branch
Web site:
http://www.antenna.co.jp/
http://www.antennahouse.com/
--------------------------------------------------*/
florin
Posts: 53

Re: Java spell checker seems to be not working

Fri Aug 07, 2015 3:52 pm

Hello,

We fixed a synchronization issue between the selected engine and the corresponding list of languages/dictionaries. But we are unable to reproduce the case when the dictionaries combo box becomes empty.
I'll send you a message on your personal e-mail, containing some details on how to configure the log system for oXygen. This way we could find out if there is any unexpected I/O error.

Best regards,
Florin
Florin Avram
<oXygen/> XML Editor
Radu
Posts: 5221

Re: Java spell checker seems to be not working

Fri Dec 18, 2015 1:26 pm

Hi,

Just to update this thread, the original issue should be fixed in Oxygen 17.1.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
tmakita
Posts: 69

Re: Java spell checker seems to be not working

Fri Dec 18, 2015 5:56 pm

Thank you for your update.
I confirmed that it works in oXygen 17.1.

Toshihiko Makita
--
/*--------------------------------------------------
Toshihiko Makita
Development Group. Antenna House, Inc. Ina Branch
Web site:
http://www.antenna.co.jp/
http://www.antennahouse.com/
--------------------------------------------------*/

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 1 guest