empty href's

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
rdelong
Posts: 71
Joined: Tue Oct 21, 2014 10:01 pm

empty href's

Post by rdelong » Wed Sep 16, 2015 1:23 am

I'm trying to troubleshoot why our xrefs that contain website URLs are coming up as

Code: Select all

<a href="" .... >
in our webhelp-mobile output. Can someone direct me to the *.XSL file that I need to check in the plugin? We've made substantial customizations to the plugin and I need to know where to start with my diagnosis.

Thanks,

bogdan_cercelaru
Posts: 221
Joined: Tue Jul 01, 2014 11:48 am

Re: empty href's

Post by bogdan_cercelaru » Wed Sep 16, 2015 2:37 pm

Hello,

I wasn't able to reproduce this using "flowers.ditamap" from sample files with the built-in "DITA Map WebHelp" transformation scenario.
I've added xrefs like:

Code: Select all


<xref href="http://www.oxygenxml.com" format="html">oXygen Site</xref>
<xref href="http://www.google.com" format="html" scope="external"/>
In the generated output the links looks like:

Code: Select all


<a href="http://www.oxygenxml.com" class="xref" onclick="return true;">oXygen Site</a>
<a href="http://www.google.com" class="xref" target="_blank" onclick="return true;">http://www.google.com</a>
The "href" attribute of "a" elements is processed in "OXYGEN_DIR\frameworks\dita\DITA-OT\plugins\com.oxygenxml.webhelp\xsl\dita\mobile\fixup.xsl" file.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply