Suddenly can't drag to move tags

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
H_Too_Oh
Posts: 44
Joined: Tue Mar 13, 2012 5:01 pm

Suddenly can't drag to move tags

Post by H_Too_Oh » Mon Aug 17, 2015 11:36 pm

I've always been able to drag DITA elements around in Author mode but suddenly for the past few days I can't. Nothing happens when I try to move a <li> tag by dragging it for example, I have to copy and paste it instead.

I just reset the global options hoping I had inadvertently changed some setting, but the problem remains.

Does anyone know why this might be?

<oXygen/> XML Editor 16.1, build 2015012213

Using DITA with full tags and attributes.

Radu
Posts: 7154
Joined: Fri Jul 09, 2004 5:18 pm

Re: Suddenly can't drag to move tags

Post by Radu » Tue Aug 18, 2015 10:36 am

Hi Jeffrey,

If resetting the options did not work (and indeed we have no setting to disable tag drag and drop) there could be two possible problems:

1) Maybe in that particular context moving the list item never worked. Does moving pieces of text (select a word and drag it) or other DITA elements still work?
2) Maybe there is a mouse hardware or driver problem, somehow the Java application does not receive anymore proper notifications when you start dragging.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

H_Too_Oh
Posts: 44
Joined: Tue Mar 13, 2012 5:01 pm

Re: Suddenly can't drag to move tags

Post by H_Too_Oh » Tue Aug 18, 2015 6:33 pm

Thanks Radu,

I rebooted the workstation and the problem vanished.

It was only affecting Oxygen, I had checked and I was still able to drag using other applications, just not in Oxygen. In any case restarting seems to have fixed it, I can now drag tags around as before. These workstations are a pain to reboot and take a long time so I don't do it often, but as usual it often fixes mysterious bugs, and did this time.


Probably something scrambled with Java as you say, but in any case that fixed it.

Post Reply