Error when adding wsp:policy to wsdl file

Questions about XML that are not covered by the other forums should go here.
ani@openminds.dk
Posts: 1

Error when adding wsp:policy to wsdl file

Tue Jun 17, 2014 12:14 pm

Hi

I am new to oxygen - and are working with webservice, eg. wsdl, ws-security and policies. However when adding wsp:policy to our wsdl file the error below occurs:

Description
cvc-complex-type.2.4.a: Invalid content was found starting with element '{"http://www.w3.org/ns/ws-policy":Policy}'. One of '{"http://schemas.xmlsoap.org/wsdl/":service, "http://schemas.xmlsoap.org/wsdl/":import, "http://schemas.xmlsoap.org/wsdl/":types, "http://schemas.xmlsoap.org/wsdl/":message, "http://schemas.xmlsoap.org/wsdl/":portType, "http://schemas.xmlsoap.org/wsdl/":binding}' is expected.
Severity
Error
System ID
/Users/MacAni/Documents/om/BD/bc-sec.wsdl
Main validation file
/Users/MacAni/Documents/om/BD/bc-sec.wsdl
Engine name
Xerces
Start location
line: 435, column: 5
End location
line: 435, column: 15
Additional info
http://www.w3.org/TR/xmlschema-1/#cvc-complex-type

Are we missing something ?

Regards
Aage Nielsen
adrian
Posts: 2336

Re: Error when adding wsp:policy to wsdl file

Tue Jun 17, 2014 3:01 pm

Hi,

Please note that currently (v16.0) Oxygen does not support ws-security and policies.

However, from what I've tested, the WSDL validation in Oxygen does not complain about the wsp:Policy.
In what context are you using wsp:Policy and get that error? Could you please provide a simple code snippet?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “General XML Questions”

Who is online

Users browsing this forum: No registered users and 1 guest