Error with "<c>" element in TEI corpus

iljackb
Posts: 4

Error with "<c>" element in TEI corpus

Fri May 23, 2014 10:22 pm

I'm encoding some documents in TEI for a language documentation project and I'm having a problem when trying to combine (valid) xml-tei documents that I have already encoded into a new corpus document.

The error I get is with the presence of the character element "<c>" which is included in the exact same context in numerous other separate/non-corpus documents and should indeed be valid being contained by "<seg>" according to the element reference page: http://www.tei-c.org/release/doc/tei-p5-doc/en/html/ref-c.html

Could someone give me any thoughts/suggestions as to why this may be?

Below is a sample of i) the error message and ii) the document

Thanks!
Jack Bowers

i)

Code: Select all

[b]E [Jing] element "c" not allowed anywhere; expected the element end-tag, text or element[/b] [size=85]"abbr", "add", "addName", "address", "affiliation", "alt", "altGrp", "anchor", "bibl", "biblFull", "biblStruct", "binaryObject", "bloc", "cb", "choice", "cit", "climate", "corr", "country", "date", "del", "desc", "distinct", "district", "email", "emph", "expan", "floatingText", "foreign", "forename", "gap", "gb", "genName", "geo", "geogFeat", "geogName", "gloss", "graphic", "hi", "idno", "index", "join", "joinGrp", "label", "lb", "lg", "link", "linkGrp", "list", "listBibl", "listEvent", "listNym", "listOrg", "listPerson", "listPlace", "location", "measure", "measureGrp", "media", "mentioned", "milestone", "name", "nameLink", "note", "num", "offset", "orgName", "orig", "pb", "persName", "placeName", "population", "ptr", "q", "quote", "ref", "reg", "region", "roleName", "rs", "said", "seg", "settlement", "sic", "soCalled", "stage", "state", "surname", "term", "terrain", "time", "timeline", "title", "trait" or "unclear"[/size]


ii)
"""

Code: Select all

         <text>
             <body>
                 <div xml:id="L093-01">
                     <head><graphic url="L093-1-what_time_is_it-6.jpg"/></head>
                     <p><seg xml:id="L093-01-01"><c>¿</c><seg xml:id="L093-01-01-01">Nchii</seg> <seg xml:id="L093-01-01-02">hora</seg> <seg xml:id="L093-01-01-03">kui</seg>[b]<c>?</c>[/b]</seg>
                         <seg xml:id="L093-01-02"><seg xml:id="L093-01-02-01">Ka</seg> <seg xml:id="L093-01-02-02">iñu</seg> <seg xml:id="L093-01-02-03">ntaa</seg>[b]<c>.</c>[/b]</seg></p>

          </>
         </>

"""
Radu
Posts: 5090

Re: Error with "<c>" element in TEI corpus

Mon May 26, 2014 8:45 am

Hi Jack,

From what I tested it depends on the modules you use for TEI validation.
The c element belongs to the analysis module.
For example if I create a TEI P5 document using the TEI All new file template in Oxygen with the following content:

Code: Select all

<?xml-model href="http://www.tei-c.org/release/xml/tei/custom/schema/relaxng/tei_all.rng" type="application/xml" schematypens="http://relaxng.org/ns/structure/1.0"?>
<?xml-model href="http://www.tei-c.org/release/xml/tei/custom/schema/relaxng/tei_all.rng" type="application/xml"
   schematypens="http://purl.oclc.org/dsdl/schematron"?>
<TEI xmlns="http://www.tei-c.org/ns/1.0">
  <teiHeader>
      <fileDesc>
         <titleStmt>
            <title>Title</title>
         </titleStmt>
         <publicationStmt>
            <p>Publication Information</p>
         </publicationStmt>
         <sourceDesc>
            <p>Information about the source</p>
         </sourceDesc>
      </fileDesc>
  </teiHeader>
  <text>
     <body>
        <div xml:id="L093-01">
           <head><graphic url="L093-1-what_time_is_it-6.jpg"/></head>
           <p><seg xml:id="L093-01-01"><c>¿</c><seg xml:id="L093-01-01-01">Nchii</seg> <seg xml:id="L093-01-01-02">hora</seg> <seg xml:id="L093-01-01-03">kui</seg><c>?</c></seg>
              <seg xml:id="L093-01-02"><seg xml:id="L093-01-02-01">Ka</seg> <seg xml:id="L093-01-02-02">iñu</seg> <seg xml:id="L093-01-02-03">ntaa</seg><c>.</c></seg></p>
        </div>
      </body>
  </text>
</TEI>


it is valid.
But if I create a TEI P5 using the TEI Bare new file template in Oxygen, the same content is invalid.

Maybe you should also write about this to the experts on the TEI Users List, they might have some suggestion about what TEI schema to use depending on your particular use case.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “TEI”

Who is online

Users browsing this forum: No registered users and 0 guests