Visual 'busy' cue

Are you missing a feature? Request it's implementation here.
GrayMan
Posts: 5
Joined: Thu May 26, 2005 9:16 pm

Visual 'busy' cue

Post by GrayMan » Thu May 26, 2005 9:26 pm

Version 6: When opening a number of (modularized) XSD files from a WebDAV server there is no visual clue (i.e., cursor change) indicating that the editor is busy. On more than one occasion I've re-clicked "Validate" only to have a message pop up saying that there is already an operation in progress. Perhaps you could consider adding a cursor change to indicate background activity.

Radu
Posts: 7535
Joined: Fri Jul 09, 2004 5:18 pm

Post by Radu » Fri May 27, 2005 10:34 am

Hi,
Version 6: When opening a number of (modularized) XSD files from a WebDAV server there is no visual clue (i.e., cursor change) indicating that the editor is busy.
When files are opened via WebDav a progress dialog appears so that adding a buzy cursor would not be necessary.
On more than one occasion I've re-clicked "Validate" only to have a message pop up saying that there is already an operation in progress. Perhaps you could consider adding a cursor change to indicate background activity.
You are probably talking about validating an XML file against a schema file from the Webdav server (or the internet). You are right, the buzy cursor does not appear. Validation is carried out on a thread leaving the user the possiblity to continue working in Oxygen without blocking while the schema is downloaded. While validating, in the status bar appears the "Validation in progress" message which we considered to be enough to notify the user the validation was not over.


Regards, Radu.

GrayMan
Posts: 5
Joined: Thu May 26, 2005 9:16 pm

Post by GrayMan » Wed Aug 31, 2005 12:32 pm

Radu wrote:When files are opened via WebDav a progress dialog appears so that adding a buzy cursor would not be necessary.
I end up fetching 50+ modularized schema from the WebDAV server when I open a typical top level schema. According to the web server log it takes about ten seconds to fetch all the schema. (Hmm, no PROPFIND requests?)

When I open the (remote) top level schema the "progress dialog" displays for about three seconds then disappears leaving me with the impression I can do something else -- but I can NOT; clicking on, for example, "Tools" does not respond until the rest of the schema tree has been fetched -- another 60 seconds or so. This makes it appear as if Oxygen has hung.

I assume that Oxygen must spend the bulk of the time working it's way through the schema tree?

Note: running 2005072105 under SuSE 9.1 Linux on an AMD64 3000 with 1GB of memory and 3Mbps downstream cable.

Radu
Posts: 7535
Joined: Fri Jul 09, 2004 5:18 pm

Post by Radu » Wed Aug 31, 2005 1:47 pm

Hello

The progress indicator that you see is for the opened schema.
After that the schema diagram viewer downloads recursively all the imported schemas in order to parse them. This operation indeed shows no progress. We placed a bug so that some visual busy cue should be seen during the operation.
If this delay bothers you, you can deactivate the schema viewer from the Options -> Preferences/Editor/Diagram page.


Regards, Radu.

GrayMan
Posts: 5
Joined: Thu May 26, 2005 9:16 pm

Post by GrayMan » Wed Aug 31, 2005 9:34 pm

Radu wrote:We placed a bug so that some visual busy cue should be seen during the operation.
Thank you.

Post Reply