V.15.2 file open dialog (crtl+O)

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
spherik
Posts: 17
Joined: Fri Jan 20, 2012 2:20 am

V.15.2 file open dialog (crtl+O)

Post by spherik » Thu Mar 27, 2014 1:18 am

Why did this basic dialog became an ugly widget, too large icons to the left, no more auto-complete (it was there previously), in summary : a pure annoyance (if you have hundreds of files).

What did I toggle to have that (if that applies) ?

adrian
Posts: 2515
Joined: Tue May 17, 2005 4:01 pm

Re: V.15.2 file open dialog (crtl+O)

Post by adrian » Thu Mar 27, 2014 3:43 pm

Hi,

Considering your description, I'm guessing you're running Oxygen in Windows and got stuck with the Java file opener. The Java file opener is used as a fail-safe mechanism in case the native file opener causes crashes in the Java runtime. But, this can also happen if Oxygen is force closed or the computer loses power while the native file open dialog is displayed.

This can be resolved by deleting a couple of files from the Oxygen options folder. Depending on the platform the options folder is located as follows:

Code: Select all

- Windows XP - [user-home-folder]\Application Data\com.oxygenxml
- Windows Vista/7/8 - [user-home-folder]\AppData\Roaming\com.oxygenxml
In Windows if you have trouble locating the AppData/Application Data folder (it is hidden), open Windows Explorer, type in the Address bar %APPDATA% and press Enter.
For v15.2, the files you have to delete to restore the native file opener are:

Code: Select all

Win32FileChooserCrashGuardoxygen15.2Sa.txt
WinFileChooserCommonCrashGuardoxygen15.2Sa.txt
Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

spherik
Posts: 17
Joined: Fri Jan 20, 2012 2:20 am

Re: V.15.2 file open dialog (crtl+O)

Post by spherik » Fri Mar 28, 2014 5:22 pm

Adrian,

Hero of my day !

Thanks a lot !

menkalos
Posts: 5
Joined: Wed May 13, 2015 11:59 pm

Re: V.15.2 file open dialog (crtl+O)

Post by menkalos » Wed Nov 08, 2017 8:47 pm

This just fixed it for me on version 19.1 as well! :-)

Post Reply