"<org.apache.fop.apps.FOPException: Specify at least one fon

Here should go questions about transforming XML with XSLT and FOP.
Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

"<org.apache.fop.apps.FOPException: Specify at least one fon

Post by Eddie » Thu Dec 26, 2013 9:23 am

Hello,
Using oXygen 15.1, ostensibly the Japanese version.

I'm getting the above error when trying to output pdf.
How do I fix it? The OS is Windows 7 (Japanese).
I've specified a Japanese font (MS Mincho) in 3 places in font-mappings.xml (the default setting doesn't work).

Was really hoping this would work out of the box, seeing as it is marketed as a Japanese version.

Full error:

重要度: error
概要: [fop] [ERROR] Anttask - Error rendering fo file: E:\DITA_OUTPUT\IMAPS\agent\temp\pdf\oxygen_dita_temp\topic.fo <org.apache.fop.apps.FOPException: Specify at least one font family
URL: http://www.oxygenxml.com/internalHelp/f ... s-dita-pdf

(The link at the bottom is broken.)

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Fri Dec 27, 2013 11:51 am

Hello,

The MS Mincho font is a TrueType font, so if MS Mincho is installed and usable on your Windows 7 computer then FOP should not have problems extracting the font metrics info from it and using it when creating the PDF output.

You can find more details about the error here (as an alternative to the broken link in the Oxygen error message).

The error message says that no font family could be loaded for PDF rendering from the list of fonts set in the font-mappings.xml file used for the DITA PDF transformation. Where exactly did you add MS Mincho in the font-mappings.xml file? What is the content of your font-mappings.xml file? Can you post it here?

You can check if the MS Mincho font is usable in Oxygen on your computer by going to menu Options -> Preferences -> Fonts, setting MS Mincho for both Editor mode and Author editing mode and testing the font for editing in Oxygen a file (text file or XML file) with Japanese characters. If the Japanese characters are displayed correctly with MS Mincho (after setting it in the Preferences dialog box) while editing a text file or XML file in the Oxygen editor window then the same characters should be rendered fine in the PDF output too. If that is not the case please send us a sample XML file with Japanese characters that you want to transform to PDF output.


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Tue Jan 07, 2014 9:36 am

Hello,
Thanks for the reply.
Sorry for the delay at my end - we've just had our long New Year holiday.

Pasted below the content of "font-mappings.xml":

Code: Select all


<font-mappings>
<font-table>

<!-- Backwards compatibility aliases -->
<aliases>
<alias name="serif">Serif</alias>
</aliases>
<aliases>
<alias name="sans-serif">Sans</alias>
</aliases>
<aliases>
<alias name="monospace">Monospaced</alias>
</aliases>
<aliases>
<alias name="Helvetica">Normal</alias>
</aliases>
<aliases>
<alias name="Courier">Monospaced</alias>
</aliases>

<logical-font name="Sans">
<physical-font char-set="default">
<font-face>Helvetica, Arial Unicode MS</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>MS Mincho</font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SubmenuSymbol">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Helvetica, Arial Unicode MS</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>

<logical-font name="Serif">
<physical-font char-set="default">
<font-face>Times New Roman, Times</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>MS Mincho/font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SubmenuSymbol">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Times New Roman, Times</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>

<logical-font name="Monospaced">
<physical-font char-set="default">
<font-face>Courier New, Courier</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>MS Mincho</font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Courier New, Courier</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>
</font-table>

</font-mappings>

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Tue Jan 07, 2014 11:16 am

Hello,

First please check that the Windows font called MS Mincho is usable from Java applications on your Windows computer, as I said above. Please go to menu Options -> Preferences -> Fonts and see if this exact name shows up in the list with all available fonts. Set *MS Mincho* for both Editor mode and Author mode and test the font by editing in Oxygen a file (text file or XML file) with Japanese characters.

If that works then we know that the font is usable for PDF output. In your font-mappings.xml file I see that you set MS Mincho only for Japanese text. That means that any Japanese text in your DITA XML files must be always enclosed in elements that have the xml:lang="ja" attribute or the xml:lang="ja-jp" attribute. Do all your Japanese text fragments meet this condition?

If you don't have the xml:lang attribute set in every topic file that contains Japanese text you can add MS Mincho to other font lists in the font-mappings.xml file for covering your actual use of the Japanese text in the DITA XML topic files. For example you can add it in all 3 "default" categories in the font-mappings.xml file:

Code: Select all

<physical-font char-set="default">
<font-face>MS Mincho, Helvetica, Arial Unicode MS</font-face>
</physical-font>

Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Wed Jan 08, 2014 8:07 am

Hello again,

All the dita files have xml:lang="ja" set.

"MS Mincho" is not available in the list of fonts to select for "Editor". I can't find a place to select for "Author". "MS 明朝" is available (Kanji for "mincho"). I set "MS Mincho" in font-mappings.xml because I found that, if I set multi-byte characters, they were ignored by the program. I made these settings based on my experience with v15, which I used for a while before v15.1. I'm 99.9% sure that I didn't have this problem with pdf output in v15.

Should I be ignoring font-mappings.xml and just making the setting in Preferences?

Cheers.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Wed Jan 08, 2014 11:27 am

Hello,
Eddie wrote:"MS Mincho" is not available in the list of fonts to select for "Editor".
That means you cannot select the font with this name (MS Mincho) in font-mappings.xml because the Java virtual machine does not find this font name and cannot use a font with this name.
Eddie wrote:I can't find a place to select for "Author". "MS 明朝" is available (Kanji for "mincho").
You set the Author font in the setting called Author default font which is available from menu Options -> Preferences -> Fonts. If the name available in the list of font names is MS 明朝 then this is the font name that you should use in the font-mappings.xml file.
Eddie wrote:I set "MS Mincho" in font-mappings.xml because I found that, if I set multi-byte characters, they were ignored by the program. I made these settings based on my experience with v15, which I used for a while before v15.1. I'm 99.9% sure that I didn't have this problem with pdf output in v15.
Do you mean the font name MS 明朝 can be used in the font-mappings.xml file and the font is loaded and used correctly in the PDF output in Oxygen 15.0, but not in Oxygen 15.1? That would be strange because the PDF transformation should work the same in 15.1, including the fonts set in the font-mappings.xml file. If you set in the font-mappings.xml file the same font name (the same characters: European, Japanese, etc) that is displayed in the list of fonts from the drop-down list available in Options -> Preferences -> Fonts then I expect the font to be loaded and used in the PDF output without problems.

If that is not the case for you can you send us please a small sample DITA map with all included DITA topics for testing the problem? Please send also the .ttf font file for MS Mincho, which you can find in the fonts directory of your operating system (for example C:\Windows\Fonts on Windows).
Eddie wrote:Should I be ignoring font-mappings.xml and just making the setting in Preferences?
No. The setting in the Preferences dialog was just for test, to see if MS Mincho is available as a usable font on your machine. This helped us find that the font name available for applications is in fact MS 明朝, not MS Mincho. The font for the PDF transformation must be set in the font-mappings.xml file, using the font name that is available for applications running on that machine (MS 明朝).


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Thu Jan 09, 2014 3:58 am

Hello again,
Sorin wrote:
Eddie wrote:"MS Mincho" is not available in the list of fonts to select for "Editor".
That means you cannot select the font with this name (MS Mincho) in font-mappings.xml because the Java virtual machine does not find this font name and cannot use a font with this name.
Eddie wrote:I can't find a place to select for "Author". "MS 明朝" is available (Kanji for "mincho").
This is getting confusing. I was looking at the Japanese interface, so I didn't realise that "作成者デフォルトフォント" = "Author". By switching between the different GUIs, I've noticed that the available fonts are different. "MS Mincho" is available to select in English mode not in Japanese mode. Likewise, "MS 明朝" is available to select in Japanese mode not in English mode. Does this mean I've got to have the GUI in Japanese in order to output PDF in Japanese?
Sorin wrote:You set the Author font in the setting called Author default font which is available from menu Options -> Preferences -> Fonts. If the name available in the list of font names is MS 明朝 then this is the font name that you should use in the font-mappings.xml file.
Eddie wrote:I set "MS Mincho" in font-mappings.xml because I found that, if I set multi-byte characters, they were ignored by the program. I made these settings based on my experience with v15, which I used for a while before v15.1. I'm 99.9% sure that I didn't have this problem with pdf output in v15.
Do you mean the font name MS 明朝 can be used in the font-mappings.xml file and the font is loaded and used correctly in the PDF output in Oxygen 15.0, but not in Oxygen 15.1? That would be strange because the PDF transformation should work the same in 15.1, including the fonts set in the font-mappings.xml file. If you set in the font-mappings.xml file the same font name (the same characters: European, Japanese, etc) that is displayed in the list of fonts from the drop-down list available in Options -> Preferences -> Fonts then I expect the font to be loaded and used in the PDF output without problems.
I'm still fairly sure I got output in Japanese using the trial version - but the memory ain't what it was and I've also been using DITA-OT and Xmetal to generate PDFs. I'll try next in Japanese mode with font-mappings.xml set to MS 明朝. For my Japanese colleagues, that would not be a problem (assuming it works), but personally I would much rather be able to use the English GUI and output pdf in Japanese. If it doesn't work, I'll send the files you asked for.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Thu Jan 09, 2014 11:55 am

Hello,
Eddie wrote:This is getting confusing. I was looking at the Japanese interface, so I didn't realise that "作成者デフォルトフォント" = "Author". By switching between the different GUIs, I've noticed that the available fonts are different. "MS Mincho" is available to select in English mode not in Japanese mode. Likewise, "MS 明朝" is available to select in Japanese mode not in English mode. Does this mean I've got to have the GUI in Japanese in order to output PDF in Japanese?

I think the font should be used correctly in both GUI versions of Oxygen (English and Japanese) as long as you set in font-mappings.xml the font name that is available in that Oxygen GUI version: "MS Mincho" in the English GUI version and "MS 明朝" in the Japanese GUI version.
Eddie wrote:I'm still fairly sure I got output in Japanese using the trial version - but the memory ain't what it was and I've also been using DITA-OT and Xmetal to generate PDFs. I'll try next in Japanese mode with font-mappings.xml set to MS 明朝. For my Japanese colleagues, that would not be a problem (assuming it works), but personally I would much rather be able to use the English GUI and output pdf in Japanese. If it doesn't work, I'll send the files you asked for.
Please try in both versions of the Oxygen GUI but set the correct font name in each GUI version: English and Japanese.


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Fri Jan 10, 2014 2:37 am

Hello again,

I've just tried the below variations: All fail with the same error (posted in the first post).
English GUI, default setting.
English GUI, MS Mincho set in 3 places for Japanese text in font-mappings.xml.
English GUI, MS Mincho set in 3 places for Japanese text and 3 places for "default".
Japanese GUI, default setting.
Japanese GUI, MS Pゴシック set in 3 places for Japanese text.
Japanese GUI, MS Pゴシック set in 3 places for Japanese text and 3 places for "default".
sorin wrote:
I think the font should be used correctly in both GUI versions of Oxygen (English and Japanese) as long as you set in font-mappings.xml the font name that is available in that Oxygen GUI version: "MS Mincho" in the English GUI version and "MS 明朝" in the Japanese GUI version.

Please try in both versions of the Oxygen GUI but set the correct font name in each GUI version: English and Japanese.
Can you get someone at your end to actually test this (i.e. output pdf from Japanese files)? And, if it works, to send me their font-mappings.xml, please.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Fri Jan 10, 2014 6:35 pm

Eddie wrote:Can you get someone at your end to actually test this (i.e. output pdf from Japanese files)? And, if it works, to send me their font-mappings.xml, please.
Do you use this MS Mincho font? This is the only free MS Mincho font that I can find, and we don't have any default font with this name already installed in Windows. If you don't use this font: where can I get your font to test with the same .ttf font file (this is important for testing in the same conditions) ? Can you send your .ttf font file?


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Tue Jan 14, 2014 4:39 am

sorin wrote: Do you use this MS Mincho font? This is the only free MS Mincho font that I can find, and we don't have any default font with this name already installed in Windows. If you don't use this font: where can I get your font to test with the same .ttf font file (this is important for testing in the same conditions) ? Can you send your .ttf font file?
I just checked the Windows Fonts folder and I can't find MS Mincho in there. MS Pゴシック is in there, though. I don't know what's going on.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Tue Jan 14, 2014 10:12 am

I don't know Japanese. Is MS 明朝 the same as MS Pゴシック? Was MS Pゴシック available in the list of fonts from menu Options -> Preferences -> Fonts?


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Tue Jan 14, 2014 10:34 am

sorin wrote:I don't know Japanese. Is MS 明朝 the same as MS Pゴシック? Was MS Pゴシック available in the list of fonts from menu Options -> Preferences -> Fonts?
Sorry, no they are different fonts. "明朝" is Mincho in kanji. "ゴシック" is Gothic in katakana. I tried with MS Pゴシック because I found it in the Options -> Preferences -> Fonts menu.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Tue Jan 14, 2014 10:57 am

You will have to use one of the fonts that is available in the list of fonts from menu Options -> Preferences -> Fonts and that contains the characters that you need (Japanese characters). If the font is not in this list it is not available for including it in the PDF output.


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Tue Jan 14, 2014 11:23 am

sorin wrote:You will have to use one of the fonts that is available in the list of fonts from menu Options -> Preferences -> Fonts and that contains the characters that you need (Japanese characters). If the font is not in this list it is not available for including it in the PDF output.
Sorry if the previous post wasn't clear: I tried using MS Pゴシック (MS PGothic) and this is available in Options -> Preferences -> Fonts in the Japanese interface. I get the same error.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Tue Jan 14, 2014 11:45 am

Do you get the error
[fop] [ERROR] Anttask - Error rendering fo file: E:\DITA_OUTPUT\IMAPS\agent\temp\pdf\oxygen_dita_temp\topic.fo <org.apache.fop.apps.FOPException: Specify at least one font family
with the MS Pゴシック (MS PGothic) font set in the font-mappings.xml file? If yes please send us your font-mappings file, the .ttf file (located in your C:\Windows\Fonts directory) of the MS Pゴシック (MS PGothic) font and a sample DITA topic or DITA map containing Japanese characters. We will have to test this font in a DITA PDF transformation that tries to load this font.


Regards,
Sorin

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Tue Jan 14, 2014 12:58 pm

Hello,

If I try with the following file font-mappings.xml that sets the font Batang for Japanese I get the correct Japanese characters in the DITA PDF output. If I remove Batang from this file I get no Japanese characters in the DITA PDF output. Can you replace your file font-mappings.xml with the following and try the PDF transformation again? Are the Japanese characters displayed correctly in the PDF output using this file font-mappings.xml?

Code: Select all

<font-mappings>
<font-table>
<aliases>
<alias name="serif">Serif</alias>
</aliases>
<aliases>
<alias name="sans-serif">Sans</alias>
</aliases>
<aliases>
<alias name="monospace">Monospaced</alias>
</aliases>
<aliases>
<alias name="Helvetica">Normal</alias>
</aliases>
<aliases>
<alias name="Courier">Monospaced</alias>
</aliases>

<logical-font name="Sans">
<physical-font char-set="default">
<font-face>Helvetica, Arial Unicode MS</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>KozMinProVI-Regular, Batang</font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SubmenuSymbol">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Helvetica, Arial Unicode MS</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>

<logical-font name="Serif">
<physical-font char-set="default">
<font-face>Times New Roman, Times</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>KozMinProVI-Regular, Batang</font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SubmenuSymbol">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Times New Roman, Times</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>

<logical-font name="Monospaced">
<physical-font char-set="default">
<font-face>Courier New, Courier</font-face>
</physical-font>
<physical-font char-set="Simplified Chinese">
<font-face>AdobeSongStd-Light</font-face>
</physical-font>
<physical-font char-set="Japanese">
<font-face>KozMinProVI-Regular, Batang</font-face>
</physical-font>
<physical-font char-set="Korean">
<font-face>AdobeMyungjoStd-Medium</font-face>
</physical-font>
<physical-font char-set="Symbols">
<font-face>ZapfDingbats</font-face>
</physical-font>
<physical-font char-set="SymbolsSuperscript">
<font-face>Courier New, Courier</font-face>
<baseline-shift>20%</baseline-shift>
<override-size>smaller</override-size>
</physical-font>
</logical-font>
</font-table>
</font-mappings>

One of the topics that I used is:

Code: Select all

<concept id="about_concept_topic" xml:lang="ja-jp">
<title>コンセプト・トピックの書き方 <concept></title>
<shortdesc>コンセプト・トピックは、「~とは何か?」という質問に対する答えを提供します。</shortdesc>
<conbody>
<p>コンセプト・トピックとタスク・トピックの違いは明白で、議論の余地がありません。一方、コンセプト・トピックとリファレンス・トピックの違いについては、議論の余地があります。コンセプト・トピックは主題について比較的幅の広い情報を提供するのに対し、リファレンス・トピックはピン・ポイントの情報を提供します。</p>
<p>コンセプト・トピックは一度だけ読まれ、その内容が読者の記憶に留まることを目指しています。一方、リファレンス・トピックは繰り返し参照され、その内容が読者の記憶に留まることを目指していません。読者が覚えたいとは思わないが、必要なときに素早く参照できなければならない情報を、リファレンス・トピックとして記述します。</p>
</conbody>
</concept>

Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Mon Jan 20, 2014 10:04 am

sorin wrote:Do you get the error
[fop] [ERROR] Anttask - Error rendering fo file: E:\DITA_OUTPUT\IMAPS\agent\temp\pdf\oxygen_dita_temp\topic.fo <org.apache.fop.apps.FOPException: Specify at least one font family
with the MS Pゴシック (MS PGothic) font set in the font-mappings.xml file?
Yes. And with other fonts that have Japanese characters in the name.
sorin wrote: If yes please send us your font-mappings file, the .ttf file (located in your C:\Windows\Fonts directory) of the MS Pゴシック (MS PGothic) font and a sample DITA topic or DITA map containing Japanese characters.
On their way.

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Mon Jan 20, 2014 10:09 am

sorin wrote: If I try with the following file font-mappings.xml that sets the font Batang for Japanese I get the correct Japanese characters in the DITA PDF output. If I remove Batang from this file I get no Japanese characters in the DITA PDF output. Can you replace your file font-mappings.xml with the following and try the PDF transformation again? Are the Japanese characters displayed correctly in the PDF output using this file font-mappings.xml?
I tried with your font-mappings.xml and it works. I then deleted stuff from my font-mappings.xml till it was exactly the same as yours and it worked. I then changed the font specification to MS UI Gothic and it still worked, so thanks for that. But, as mentioned above, I still can't use fonts with Japanese in the name.

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Mon Jan 20, 2014 10:44 am

Eddie wrote:On their way.
As soon as I find out how to send the ttf file - is the problem because it's ttc?

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Mon Jan 20, 2014 4:03 pm

Eddie wrote:I then changed the font specification to MS UI Gothic and it still worked, so thanks for that.
If MS UI Gothic displays the Japanese characters in the PDF output you just found a solution: use the MS UI Gothic font instead of Mincho.


Regards,
Sorin

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Mon Jan 20, 2014 4:08 pm

Eddie wrote:
Eddie wrote:On their way.
As soon as I find out how to send the ttf file - is the problem because it's ttc?
A .ttc font is a collection of .ttf fonts so it should work. For example Batang is also a .ttc font and you said Batang worked for you in the PDF output for Japanese characters just as it worked for me.

So please send the Mincho .ttc file that you try to use. Just copy the path of the .ttc file from the file system of your operating system in the File Attachment text box of our problem report form.


Regards,
Sorin

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Tue Jan 28, 2014 3:04 am

Hello,

Sorry for the delay.
sorin wrote:So please send the Mincho .ttc file that you try to use. Just copy the path of the .ttc file from the file system of your operating system in the File Attachment text box of our problem report form.
Sorin
And sorry if this sounds daft, but I can't do this. When I try to specify it from the Browse button, it isn't displayed. (Fewer than half of the fonts shown in Explorer are displayed when accessed via the Browse button.)

Incidentally, I found out why my font-mappings.xml wasn't working for so long: there was a "<" missing (see the version attached to the third (I think) post. Still doesn't work with MS Pゴシック etc, though.

Eddie
Posts: 106
Joined: Wed Dec 18, 2013 3:07 am

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by Eddie » Wed Apr 23, 2014 9:00 am

Hello,

Just installed 15.2 and found that you've fixed this. Well done.

If you could get out some Japanese documentation, you could make a killing here!

Cheers.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: "<org.apache.fop.apps.FOPException: Specify at least one

Post by sorin_ristache » Wed Apr 23, 2014 9:58 am

Eddie wrote:If you could get out some Japanese documentation, you could make a killing here!
Do you mean a Japanese version of the User Manual? We will consider that but probably a Japanese version will not be added in the short to medium term.


Regards,
Sorin

Post Reply