URL produced by WebHelp contain two hash tags

pault
Posts: 69
Joined: Thu Mar 21, 2013 12:55 am

URL produced by WebHelp contain two hash tags

Post by pault » Thu Aug 08, 2013 8:15 pm

When you generate WebHelp, it produces some URLs containing two hash tags. For example, in the Oxygen Editor docs:

http://www.oxygenxml.com/doc/ug-editor/ ... tup-script

The problem that we have is that sometimes when you give the URL to a customer, the second hash tag is converted to %23 by the browser (particularly Safari) and the link is broken:

http://www.oxygenxml.com/doc/ug-editor/ ... tup-script

After researching this it it appears that is not RFC-3986 compliant.

It would be greatly appreciated if this was fixed.

Thanks,

Paul

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: URL produced by WebHelp contain two hash tags

Post by sorin_ristache » Fri Aug 09, 2013 3:17 pm

Hi Paul,

Please can you post here or send us an example of input that generates Webhelp output pages containing such links (with two '#' characters)? I think the Oxygen User Manual available on this website does not contain such links, or maybe I just cannot find them.

Where are these links: in the Webhelp page content, in the navigation bar at the top of the page, etc? How can I get such links in the output of an Oxygen Webhelp transformation?


Thank you,
Sorin

pault
Posts: 69
Joined: Thu Mar 21, 2013 12:55 am

Re: URL produced by WebHelp contain two hash tags

Post by pault » Tue Aug 13, 2013 3:45 pm

Hi Sorin,

I don't know why I can't repeat what I did on the Oxygen Editor help to get the URL I sent you, but here's an example from our web site. I'll upload the files later today.

Go to http://www.datastax.com/documentation/c ... index.html and in the content pane, click Virtual nodes (the second bullet item). The link displayed in the location/search field is

http://www.datastax.com/documentation/c ... syz_4mf_fk

Paul

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: URL produced by WebHelp contain two hash tags

Post by sorin_ristache » Mon Aug 19, 2013 5:32 pm

Hi Paul,

For removing the second '#' from the links please replace the file:

[Oxygen-15.0-install-dir]\frameworks\dita\DITA-OT\plugins\com.oxygenxml.webhelp\oxygen-webhelp\resources\skins\desktop\toc.js

with this toc.js file. We will include this fix also in the next maintenance build of version 15.0.


Regards,
Sorin

pault
Posts: 69
Joined: Thu Mar 21, 2013 12:55 am

Re: URL produced by WebHelp contain two hash tags

Post by pault » Wed Aug 21, 2013 6:27 am

Hi Sorin,

I installed the toc.js file as described, but many URLs still have two hash marks. I also tried running our files with the unmodified DITA Map WebHelp scenario (except for setting clean.output to yes) with the same results. I also checked that the new toc.js file was copied to the output directory and it was.

I'll upload the output files. You already have the source files I uploaded earlier.

Paul

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: URL produced by WebHelp contain two hash tags

Post by sorin_ristache » Fri Sep 06, 2013 4:27 pm

Hi Paul,

We fixed the problem with the URIs that contain the encoded '%23' character. Please replace again your file

[Oxygen-15.0-install-dir]\frameworks\dita\DITA-OT\plugins\com.oxygenxml.webhelp\oxygen-webhelp\resources\skins\desktop\toc.js

with this new toc.js file for fixing the problem.


Regards,
Sorin

pault
Posts: 69
Joined: Thu Mar 21, 2013 12:55 am

Re: URL produced by WebHelp contain two hash tags

Post by pault » Tue Sep 10, 2013 6:13 pm

Thanks Radu.

runleonarun
Posts: 9
Joined: Wed May 08, 2013 11:20 pm

Re: URL produced by WebHelp contain two hash tags

Post by runleonarun » Wed Oct 28, 2015 1:21 am

Hello. I am having a problem with this too. We have the Webhelp plugin living in our own version of the toolkit (1.7.5) in case that matters.

My second hash, which is a link that points to an anchor within the same page is being converted by my webhelp plugin to a double underscore. For some reason now the link goes to the bottom of the page instead of to the anchor. Here's an example of this behavior:

https://docs.jivesoftware.com/cloud_int ... rtsv3.html

I tried replacing the toc.js from the toolkit that came with my Oxygen 16, but that did not work either. Any ideas?
Also, my toc.js is not in the location you indicated above, it's actually in DITA-OT\plugins\com.oxygenxml.webhelp\oxygen-webhelp\resources\js\toc.js

Thanks! Leona

bogdan_cercelaru
Posts: 214
Joined: Tue Jul 01, 2014 11:48 am

Re: URL produced by WebHelp contain two hash tags

Post by bogdan_cercelaru » Wed Oct 28, 2015 6:18 pm

Hello,
I tried replacing the toc.js from the toolkit that came with my Oxygen 16, but that did not work either. Any ideas?
Also, my toc.js is not in the location you indicated above, it's actually in DITA-OT\plugins\com.oxygenxml.webhelp\oxygen-webhelp\resources\js\toc.js
Please note that this topic discusses the toc.js from version 15.0 of Oxygen which is kept in a different location and is significantly different than the one in v16 and later.
In other words, please don't use with v16 and later the toc.js linked here.

There is a known issue in v16 with the interpretation of relative anchors that point within the same page. This particular problem has been fixed since the latest maintenance build of v16.1, available here:
oXygen XML Editor Version 16.1 Download

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply