Receiving erro "Open quote is expected for attribute "name"

This should cover W3C XML Schema, Relax NG and DTD related problems.
altein
Posts: 13

Receiving erro "Open quote is expected for attribute "name"

Tue May 11, 2010 12:56 am

I'm new to XML Schema, and am trying to modify code that I acquired to generate a custom form in Acrobat. I've included the code below. I wanted to use Oxygen's designer feature for creating XML Schema so that I can modify the form, but am receiving an error for the XML Schema in the code editor, and thus can't use the designer feature of Oxygen.

The error I am receiving is "
F [Xerces] Open quote is expected for attribute "name" associated with an element type "xsd:element".

I am receiving the error at the declaration of the first element.

Below is the code.

Code: Select all

 <?xml version="1.0" encoding="UTF-8"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <xsd:element name=”mySubForm”>
    <xsd:complexType>
      <xsd:sequence>
        <xsd:element name=”phone”>
          <xsd:complexType>
            <xsd:simpleContent>
              <xsd:extension base=”xsd:string”>
                <xsd:attribute name=”phoneType” use=”required”>
                <xsd:simpleType>
                  <xsd:restriction base=”xsd:string”>
                    <xsd:enumeration value=”01 - Work”/>
                    <xsd:enumeration value=”02 - Fax”/>
                    <xsd:enumeration value=”03 - Cell”/>
                    <xsd:enumeration value=”04 - ISDN”/>
                    <xsd:enumeration value=”05 - Home”/>
                    <xsd:enumeration value=”06 - Pager”/>
                    <xsd:enumeration value=”07 - Home Fax”/>
                    <xsd:enumeration value=”08 - Other”/>
                    </xsd:restriction>
                 </xsd:simpleType>
                </xsd:attribute>
           </xsd:extension>
        </xsd:simpleContent>
    </xsd:complexType>
    </xsd:element>
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
</xsd:schema>


Any help would be appreciated.
adrian
Posts: 2461

Re: Receiving erro "Open quote is expected for attribute "name"

Tue May 11, 2010 11:46 am

Hello,

Apparently you have in your schema an unsupported type of quote(”) character. Simply open the Find/Replace dialog(Ctrl + F) and replace all ” characters with " and it should work fine afterwards.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
altein
Posts: 13

Re: Receiving erro "Open quote is expected for attribute "name"

Tue May 11, 2010 7:08 pm

Thank you. It works fine now.
Dark Penguin
Posts: 1

Re: Receiving erro "Open quote is expected for attribute "na

Mon Jun 24, 2013 6:40 am

I really thought this would correct the same issue for me, since it looked like I didn't have the correct quote character. As it turned out though, my IDE (Eclipse Juno) italicizes lvalues by default, so they're really straight-up quotation marks.
Radu
Posts: 5867

Re: Receiving erro "Open quote is expected for attribute "na

Tue Jun 25, 2013 8:30 am

Hi,

If you have any more problems with this issue you could send us a sample document at support@oxygenxml.com

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “XML Schemas”

Who is online

Users browsing this forum: No registered users and 0 guests