Hard line return in text documents

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Roger
Posts: 26
Joined: Tue Apr 05, 2005 11:29 pm

Hard line return in text documents

Post by Roger » Wed Apr 06, 2005 8:42 pm

How do you do that? I can set hard line returns in java and xsl documents but not text. Is this supposed to be a word processor or a programmer's editor? I don't understand the feature.

Thanks again

Roger

george
Site Admin
Posts: 2102
Joined: Thu Jan 09, 2003 2:58 pm

Post by george » Thu Apr 07, 2005 2:23 pm

Hi Roger,

I do not understand the problem. Please give us more details, what you are doing, what you get and what is the expected result.

Best Regards,
George

Roger
Posts: 26
Joined: Tue Apr 05, 2005 11:29 pm

Post by Roger » Fri Apr 08, 2005 1:39 am

File>New>text

Type some text on line one. then hit the <enter> key.

I expect the caret to move to line 2 as it just did while typing this message.

The actual result is that the <Enter> key is ignored. I'm still left typing on line one.

Doing the same thing with a new Java document produces the expected result. The caret is moved to the next line down.

I'm using Java 1.5.0_01-b08

Thanks,

Roger

Radu
Posts: 7579
Joined: Fri Jul 09, 2004 5:18 pm

Bug indeed

Post by Radu » Fri Apr 08, 2005 8:40 am

Hi Roger,

Thanks for the input. This is indeed a bug.

An option that should have only interfered with xml style documents (the "Enable Smart Enter" option in the Preferences/Editor/Format page which is selected by default) interferes with the text editor causing an internal exception to occur.
As a workaround you can uncheck the option and the Enter key will work again in the text editor.

Sorry about that, we focused on testing the xml editors and apparently neglected the simplest one which was the text editor.

Regards, Radu.

george
Site Admin
Posts: 2102
Joined: Thu Jan 09, 2003 2:58 pm

Post by george » Fri Apr 08, 2005 10:27 am

Hi,

Just to make clear that this problem is not present in the 5.1 release. I posted a development snapshot on the saxon-help mailing list for the users interested to use the debugger with the latest version of saxon and the problem is in that *development snapshot*.
The development snapshot may contain other problems - it is not a release, not even an alpha release. We will appreciate reporting these problems but please always mark the fact that they are in the development snapshot and not in the current release.
Also, Roger, in case you did not noticed my recent post on saxon-help, we made available a development snapshot with support for Saxon 8.4:
http://www.oxygenxml.com/update/saxon8.4/oxygen.tar.gz

Best Regards,
George

Post Reply