Problem with href in the author component

Post here questions and problems related to oXygen frameworks/document types.
sebastienlavandier
Posts: 124
Joined: Tue May 29, 2012 5:42 pm

Problem with href in the author component

Post by sebastienlavandier » Tue Nov 27, 2012 11:21 am

Hello,

I have a problem when I click on an href in the Author component.

When I try this xml fragment in the Author component, and when i click on the href, the linked CSS is lost with the message "Cannot load the associatee CSS file(s). The error was : No CSS file specified ! ...
Yet the sames xml fragment works well in the Author Oxygen.

<dmRef xlink:type="simple" xlink:actuate="onRequest" xlink:show="replace"
xlink:href="#S1000DBIKE-AAA-D00-00-00-00-AA-041-A-A">
<dmRefIdent>
<dmCode modelIdentCode="S1000DBIKE" systemDiffCode="AAA" systemCode="D00" subSystemCode="0"
subSubSystemCode="0" assyCode="00" disassyCode="00" disassyCodeVariant="AA" infoCode="041"
infoCodeVariant="A" itemLocationCode="1"/>
</dmRefIdent>
</dmRef>

<dmRef id="S1000DBIKE-AAA-D00-00-00-00-AA-041-A-A" xlink:type="simple" xlink:actuate="onRequest"
xlink:show="replace">
<dmRefIdent>
<dmCode modelIdentCode="S1000DBIKE" systemDiffCode="AAA" systemCode="D00" subSystemCode="0"
subSubSystemCode="0" assyCode="00" disassyCode="00" disassyCodeVariant="AA" infoCode="041"
infoCodeVariant="A" itemLocationCode="1"/>
</dmRefIdent>

Could you help me ?
Do you have an idea ?

Thanks in advance for your answer.
Sébastien.

Radu
Posts: 6452
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problem with href in the author component

Post by Radu » Tue Nov 27, 2012 12:19 pm

Hi Sébastien,

So when you click on an HREF in the Author Component there is code in the AuthorComponentSample:

Code: Select all

factory.setOpenURLHandler(.....
which sets a handler which will react to this event. The handler in this case sets the URL of the followed resource to the AuthorComponent. Did you change this code in any way? If not, is it appropriate for the behavior you want?

What do you mean by linked CSS? Do you have a processing instruction in the XML which points to a certain CSS? If so, is the CSS located in the proper location on the server?
If not, do you have a document type/framework which comes bundled with the applet and recognizes this type of XML files (has association rules matching it)?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

sebastienlavandier
Posts: 124
Joined: Tue May 29, 2012 5:42 pm

Re: Problem with href in the author component

Post by sebastienlavandier » Mon Dec 03, 2012 1:05 pm

Hello Radu

thank you again for your help.
Now, it works well !
I just replaced .load() by .showLocation() on :

Code: Select all


factory.setOpenURLHandler(new OpenURLHandler() {
public void handleOpenURL(URL arg0) throws IOException {
try {
//authorComponent.load(arg0, null);
authorComponent.showLocation(arg0);
} catch (AuthorComponentException e) {
throw new IOException(e.getMessage());
}
}
});
Regards.

Radu
Posts: 6452
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problem with href in the author component

Post by Radu » Mon Dec 03, 2012 1:15 pm

Hi Sebastien,

Indeed, the Author Component Project corresponding to Oxygen version 14.1 already had this modification made in the AuthorComponentSample class.
The showLocation method was added in 14.1 to solve problems like yours.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

sebastienlavandier
Posts: 124
Joined: Tue May 29, 2012 5:42 pm

Problem with href in the author component

Post by sebastienlavandier » Fri Apr 19, 2013 4:32 pm

Hi Radu,

In fact that's work well, but I don't understand why when I use the author component with an XP workstation the href link don't run and I have this error :

Code: Select all


[ro.sync.io.win.WindowsNativeHelper] Could not load the native Win32 library: java.lang.UnsatisfiedLinkError: no WindowsNativeHelper32 in java.library.path
Do you have an idea to solve this ?
Thanks in advance.

Sébastien.

Radu
Posts: 6452
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problem with href in the author component

Post by Radu » Mon Apr 22, 2013 11:15 am

Hi Sébastien,

The warning you receive in the Java console is not important, intentionally the component does not have some native bundled DLLs with it in order to use the native file chooser. So you should ignore it.

The warning should not be related in any way to the fact that the link is not correctly opened. Link navigation should work (or not work) consistently on any operating system. Maybe you should add more logging on your side to find the problem.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply