UNICODE Support in internal links

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
fsteimke
Posts: 49
Joined: Tue Jan 01, 2013 3:19 pm

UNICODE Support in internal links

Post by fsteimke » Wed Apr 17, 2013 11:12 am

Hi,

i am working with docbook. If have an Element with an xml:id Attribute and an xref-Element which linkend-attribute points to this particular id. The result is -in author mode- an internal hyperlink. Usually this works very well.

In my case, the value of @xml:id is 'def.konformität'. 'ä' is 'LATIN SMALL LETTER A WITH DIAERESIS'. The effect is:
  • File is valid with respect to the DocBook 5 Schema. This includes the existence of the target for every @linkend.
  • But when i click the Link in Author-Mode, Oxygen says 'Reference: def.konformit%C3%A4t was not found.'
OS is Windows 7 (64 bit), Oxygen is 14.2

The obvious solution is to stick with ascii characters for the value of ID-Attributes. But since 0xE4 is a valid character for XML Names, it seems to be a (minor) bug.

Sincerely,
Frank

adrian
Posts: 2674
Joined: Tue May 17, 2005 4:01 pm

Re: UNICODE Support in internal links

Post by adrian » Wed Apr 17, 2013 11:42 am

Hello,

Thank you for letting us know about this.

I can confirm this is a bug in the link following mechanism from the Author mode. I've submitted this to our issue tracking tool to be investigated and resolved in the next release of Oxygen.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Radu
Posts: 7148
Joined: Fri Jul 09, 2004 5:18 pm

Re: UNICODE Support in internal links

Post by Radu » Mon Jun 10, 2013 10:52 am

Hi Frank,

We just released Oxygen 15.0 and it should have a fix for this issue.
You will probably receive a notification mail on the new release in a couple of days.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply