huge problem: fop (xsl:fo parser) registering fonts (linux)

Here should go questions about transforming XML with XSLT and FOP.
david2k

huge problem: fop (xsl:fo parser) registering fonts (linux)

Thu Sep 23, 2004 2:20 pm

first of all sorry for my bad english... :lol:

my problem is to register fonts for fop on linux. i get following error message: [ERROR] unknown font xxxx, so defaulted font to any

i exactly followed the font registering mechanism on the fop site (http://xml.apache.org/fop/). i wonder why it doesnt work! becase on windows it works great!

have someone encountered the same problem? have someone an working fop on linux?


thank you and greetings from david...
sorin_ristache
Posts: 4144

Fri Sep 24, 2004 6:10 pm

Hello David,

Registering FOP fonts and using them to generate documents with FOP works on Windows AND Linux. Are you sure you set the FOP configuration file in <oXygen/> as it is described in http://www.oxygenxml.com/doc/ug-oxygen/preferences-fo-processors.html ? When you set everything correctly FOP still gives the error message about the unknown font so you can ignore it. Make sure you follow all the steps in the article http://www.oxygenxml.com/doc/articles/AddFontToFOP/addFontToFOP.pdf. It worked for me. If it doesn't work for you tell us what font you are trying to register, what error messages you see, post your FOP configuration file.

Hope that helps,
Sorin

Return to “XSLT and FOP”

Who is online

Users browsing this forum: No registered users and 3 guests