Elements view and NVDL

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
sijomon
Posts: 83
Joined: Wed May 20, 2009 1:18 pm

Elements view and NVDL

Post by sijomon » Tue May 18, 2010 12:46 pm

Hi,

Its been a little while since I worked with Oxygen, but I have another question which I'm stuck with and am hoping you can help.

We have an XML document which uses NVDL validation. In order to trigger this validation we include the <?oxygen NVDLSchema> PI, and also remove the schemaLocation from the root element. Failure to remove the root element casues the tag completion function, as accessed by <enter> in author mode or typing '<' in test mode, to only prompt you with those tags that are avaiable at that location as identifed by the root element's schema and not those which are identified via the nvdl file.

The problem we have is that the 'elements' view panel only ever prompts with those tags that are avaiable from the root element's schema and never shows those that are identified via the nvdl file for the node in question's namespace.

This issue is present in Oxygen 10.3 and 11.2

Can you offer any assistance?

Many thanks,

Simon.

adrian
Posts: 2548
Joined: Tue May 17, 2005 4:01 pm

Re: Elements view and NVDL

Post by adrian » Tue May 18, 2010 2:28 pm

Hello,

So only the Elements view is missing the correct tags from the nvdl?
And if you press ENTER(content completion) in the Author you find the tags from the nvdl?

Have you tried using Document -> Validate -> Reset Cache and Validate?
This should reset and update the cached schema, but I guess if it wasn't updated then the old tags would still be presented even in the content completion window(ENTER or Ctrl+Space).

I've checked this problem but I can't reproduce it on our NVDL sample: [oxygen-installation-folder]/samples/nvdl/xhtml-xforms.xml

This sample document has an oxygen PI that points to an NVDL for XHTML+XForms:

Code: Select all

<?oxygen NVDLSchema="xhtml-xforms.nvdl"?>
I can switch it to plain XHTML 1.1 by using the root with:

Code: Select all

<html xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.w3.org/1999/xhtml http://www.w3.org/MarkUp/SCHEMA/xhtml11.xsd"
I could switch back and forth between the XHTML XML schema and XHTML+XForms NVDL schema and everything including the Elements view seemed to be updated in correspondence with the current schema.

Can you try this sample and let me know how it behaves to you?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

adrian
Posts: 2548
Joined: Tue May 17, 2005 4:01 pm

Re: Elements view and NVDL

Post by adrian » Tue May 18, 2010 2:43 pm

Hi,

I've looked a little harder and I think you have a point. I see something similar to what you're describing happening in the sample I mentioned.
e.g. inside an xforms:textarea the CC shows a lot of HTML elements and an xforms:label element in the list of tags. But in the Elemnents view there's only xforms:label.

I'll add this problem to our bug tracking list.
Thank you for reporting it.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

sijomon
Posts: 83
Joined: Wed May 20, 2009 1:18 pm

Re: Elements view and NVDL

Post by sijomon » Thu May 20, 2010 2:08 pm

Many thanks for following this up.

Glad to have it confirmed.

Simon.

Post Reply