Author mode - css behaviour in 11.1

<oXygen/> general issues.
honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Author mode - css behaviour in 11.1

Post by honyk » Fri Dec 18, 2009 3:47 pm

Hello,

during testing the 11.1 version I've found the different behaviour of CSS styles in the 'no tags' view.

I have a modified style for indexterms in section titles:

Code: Select all

indexterm {
display: block;
font-weight: bold;
}
While the full tags mode looks quite the same (11/11.1):
Image
Image

No tags mode is different (11/11.1):
Image
Image
There is an extra space before the content (probably for the tag, but this is not present) and the space between inline is narrower.

I think this cannot be avoided by css styles and mainly this extra space at the beginning, visible also on different places makes strange gaps in the text.

Jan

iulian_velea
Posts: 63
Joined: Fri Dec 12, 2003 6:34 pm
Contact:

Re: Author mode - css behaviour in 11.1

Post by iulian_velea » Fri Dec 18, 2009 5:12 pm

Hello Jan,

The standard "docbook.css" was modified between the two versions, I think.
The following section, related to the "secondary" element, was introduced:

Code: Select all


secondary,
tertiary{
padding-left:2px;
}
So there is no real space in the document there is just a gap obtained when rendering it.

If you want this gap to disappear you can add the following section to your custom CSS and see if it works:

Code: Select all


indexterm, 
secondary,
primary,
tertiary {
padding-left: 0px;
}
Regards,
Iulian

honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Re: Author mode - css behaviour in 11.1

Post by honyk » Fri Dec 18, 2009 6:10 pm

Thanks for the tip, adding 2 px really solves the minor issue. But what about the 'major' one, the vertical indent?

I've found it everywhere when the original css value of the content:before property was set to empty by me: title/indexterm, note/para, footnote/para:

Code: Select all

footnote:before{
display:inline;
content: "";
color:#333333;
background-color:inherit;
}
In 11 version such the empty content wasn't displayed on the separate line in the 'no tags' view...

iulian_velea
Posts: 63
Joined: Fri Dec 12, 2003 6:34 pm
Contact:

Re: Author mode - css behaviour in 11.1

Post by iulian_velea » Fri Dec 18, 2009 6:52 pm

Hello,

The empty line that appears where the "title:before" content used to be may represent a regression from version 11. I added an entry on our issue tracker that will be analyzed by our development team.
We will let you know when it will be closed.

Thank you,
Iulian.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Author mode - css behaviour in 11.1

Post by sorin_ristache » Wed Jan 20, 2010 3:24 pm

Hello,

I just wanted to let you know that we fixed the empty line problem. The fix will go in the next version of Oxygen Author, that is version 11.2.


Regards,
Sorin

honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Re: Author mode - css behaviour in 11.1

Post by honyk » Mon Jan 25, 2010 1:33 pm

Thanks for this info. Is there already any due date for this release? Can we count with weeks or rather months?

adrian
Posts: 2604
Joined: Tue May 17, 2005 4:01 pm

Re: Author mode - css behaviour in 11.1

Post by adrian » Mon Jan 25, 2010 1:39 pm

Hi,

11.1 has just been released in December 2009 so we're talking about a few months until 11.2 is released.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply