XSLT 3.0 Streaming and SQL Extension

Here should go questions about transforming XML with XSLT and FOP.
random1980
Posts: 4
Joined: Mon Nov 25, 2019 5:49 pm

XSLT 3.0 Streaming and SQL Extension

Post by random1980 » Mon Nov 25, 2019 6:10 pm

I am trying to get to work Saxon-EE 9.8.0.12 with XSLT 3.0 streaming enabled as well as the Saxon SQL extension. I'm using it with the Oxygen XML Developer IDE.

In the transformation scenario settings, I have activated Enabled streaming mode.

For the SQL extension, I have activated Use a configuration file. My config file looks like this:

Code: Select all

<configuration xmlns="http://saxon.sf.net/ns/configuration" edition="EE">
  <global allowExternalFunctions="true" versionOfXml="1.0"/>
  <global streamability="on"/>
   <xslt>
    <extensionElement namespace="http://saxon.sf.net/sql"
      factory="net.sf.saxon.option.sql.SQLElementFactory"/>
  </xslt>
</configuration>
However, as soon as I activate Use a configuration file, streaming stops working and it throws the following message:
The unnamed mode is streamable, but the input is not supplied as a stream. Edit the transformation scenario and select the option "Enable streaming mode" in the configuration of the Saxon transformer engine.
Can this problem be resolved? Thanks for your help.

random1980
Posts: 4
Joined: Mon Nov 25, 2019 5:49 pm

Re: XSLT 3.0 Streaming and

Post by random1980 » Tue Nov 26, 2019 12:25 pm

@Admin: Could you please fix my post's title and change it to "... and SQL Extension".
Thanks! :D

random1980
Posts: 4
Joined: Mon Nov 25, 2019 5:49 pm

Re: XSLT 3.0 Streaming and SQL Extension

Post by random1980 » Tue Nov 26, 2019 7:55 pm

Hello,
Maybe the problem is not the SQL Extension at all.

I ran an experiment and noticed that even if I provide an empty config file, I keep getting the error message:
Engine name: Saxon-EE 9.8.0.12
Severity: error
Description: The unnamed mode is streamable, but the input is not supplied as a stream. Edit the transformation scenario and select the option "Enable streaming mode" in the configuration of the Saxon transformer engine.
My config file contained nothing but:

Code: Select all

<configuration xmlns="http://saxon.sf.net/ns/configuration" edition="EE">
</configuration>
Could it be that I need to provide the name of a Saxon license file in the configuration element? As stated in my initial posting, I am using Saxon as part of Oxygen XML Developer.

I would be thankful for any advice on how to proceed to solve the issue.

tavy
Posts: 188
Joined: Thu Jul 01, 2004 12:29 pm

Re: XSLT 3.0 Streaming and SQL Extension

Post by tavy » Wed Nov 27, 2019 11:00 am

Hello,

You don't need a Saxon EE licence if you are transforming from Oxygen. It seems that there is a problem when you set the stremming mode from the configuration file.If you enable the stremming mode from the Saxon configuration dialog options, by checking "Enable streaming mode", and you uncheck the "Use a configuration file" option, the stremming mode works.
I added an issue to analyze this problem. We will update this thread when we will find a solution.

Also , the configuration file is not valid, should be something like this:

Code: Select all

<configuration xmlns="http://saxon.sf.net/ns/configuration" edition="EE">
  <global allowExternalFunctions="true" versionOfXml="1.0" streamability="standard"/>
   <xslt>
    <extensionElement namespace="http://saxon.sf.net/sql"
      factory="net.sf.saxon.option.sql.SQLElementFactory"/>
  </xslt>
</configuration>
I tested with <oXygen/> XML Developer 21.1, build 2019090904.

Best Regards,
Octavian
Octavian Nadolu
<oXygen/> XML Editor
http://www.oxygenxml.com

random1980
Posts: 4
Joined: Mon Nov 25, 2019 5:49 pm

Re: XSLT 3.0 Streaming and SQL Extension

Post by random1980 » Wed Nov 27, 2019 12:20 pm

Hello,

Thanks for getting back.

This is exactly my observation.

Yes, please keep me updated in this thread. Thanks for your help.

Post Reply