Webhelp responsive - not having an index results in errors

mdslup
Posts: 46

Webhelp responsive - not having an index results in errors

Mon Jul 30, 2018 9:38 pm

Webhelp Responsive in Oxygen 20

My webhelp responsive doesn't have an index (I don't need one for this particular situation).

In my webhelp responsive transformation output, I get an error:

java.io.FileNotFoundException: C:\GitDocs\Manuals - Deep\out\webhelp-responsive\index.xml (The system cannot find the file specified) Cause: java.io.FileNotFoundException: C:\GitDocs\Manuals - Deep\out\webhelp-responsive\index.xml (The system cannot find the file specified)


Additionally, when the page loads, I get 2 Javascript errors:

Failed to load resource: net::ERR_FILE_NOT_FOUND oxygen-webhelp/app/search/index/keywords.js:1

Uncaught Error: Script error for "keywords", needed by: searchAutocomplete
http://requirejs.org/docs/errors.html#scripterror
at makeError (require.js:5)
at HTMLScriptElement.onScriptError (require.js:5)


How do I tell Oxygen I am not using an index to get rid of these?
ionela
Posts: 204

Re: Webhelp responsive - not having an index results in errors

Tue Jul 31, 2018 11:43 am

Hello,

The index.xml file is used to collect the indexterms from the ditamap, so this file cannot be skipped during the WebHelp Responsive output generation.
However, we are not aware of these kind of errors. Do you run the default DITA Map WebHelp Responsive transformation scenario or a customized one?
In case you are using a customized scenario could you please try to run the default one as the error might be trigger by some customizations?
If the problem persists, please create a minimal valid sample ditamap and send it to us to reproduce this error on our side. Please send the valid sample to our support email address support [AT] oxygenxml [DOT] com.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support
mdslup
Posts: 46

Re: Webhelp responsive - not having an index results in errors

Tue Jul 31, 2018 10:49 pm

Email sent.

Can I just use a blank index? If so, where does the index file go?
ionela
Posts: 204

Re: Webhelp responsive - not having an index results in errors

Wed Aug 08, 2018 4:01 pm

Hi,

Just to update the thread, this error occurred when the ditamap does not contain any reference to a topic which is not valid use-case for a production environment.

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest