loss of pretty-print when copying to clipboard

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
jokester01au
Posts: 64
Joined: Tue May 17, 2005 9:16 am

loss of pretty-print when copying to clipboard

Post by jokester01au » Tue May 17, 2005 9:52 am

It appears that Oxygen 5.1 has introduced a bug with regard to copying markup out of Oxygen and into a word processor etc.

In previous versions, text would be placed on the clipboard in RTF - retaining all syntax colouring and font settings. In version 5.1 it is copied as plain text.

This is the case for both the eclipse plugin and standalone versions.

I have found this feature to be very useful. I hope that it hasn't been deprecated.

Regards,
Joe.

george
Site Admin
Posts: 2101
Joined: Thu Jan 09, 2003 2:58 pm

Post by george » Tue May 17, 2005 1:20 pm

Hi Joe,

This worked in the past only on Eclipse and it was a feature of the framework, that is not something built into oXygen. This was changed in Eclipse and it is not available anymore (this can be seen also if you copy and paste content from the Eclipse Java editor).

Best Regards,
George

jak09
Posts: 2
Joined: Fri Oct 29, 2004 3:52 am

pretty print copy to clipboard

Post by jak09 » Thu May 19, 2005 6:40 am

George,

Thanks for your reply.

I am a little confused, however, because I have tested oxygen and eclipse with the following versions and results

Eclipse build Oxygen Version RTF copy to clipboard
3.1M6 5.0 Yes
3.1M6 5.1 No
3.1M7 5.0 Yes
3.1M7 5.1 No

Also Eclipse Java code is and - to my recollection - always was copied as plain text.

These things seem to suggest that Oxygen is the common element?

Regards,
Joe.

Post Reply