Slow text editing

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
ChrisCrawford
Posts: 1
Joined: Thu May 05, 2005 6:55 pm

Slow text editing

Post by ChrisCrawford » Thu May 05, 2005 8:34 pm

I'm having serious problems with text editing speed. The delay between my keypress and the character registering on the screen is somewhere between 300 and 500 ms; that's slow enough that I can't touchtype, and lead to lots of typos.

I'm running Oxygen on a 1.25 GHz G4 Mac under OS 10.3.9. When typing text, the CPU saturates at about 85% - 90% usage for Oxygen. MY XML document is about 1000 lines long. This is not a problem with small files of under 100 lines. However, when I tried it on a 4000-line XML file, Oxygen seemed to run no more slowly than with the 1,000 line XML file.

I tried turning off all the options that might slow things down, but so far have had no luck. I've used plenty of other java programs without this problem.

Is this problem correctable, or is the only solution to get a faster machine?

adaml
Posts: 1
Joined: Thu Jan 05, 2006 10:04 pm

Similar problems

Post by adaml » Thu Jan 05, 2006 10:09 pm

I'm having similar problems; I'll try to provide as many details as I can. First had the problem with an XSL file of about 2000 lines. I'm using Oxygen as an Eclipse plugin on Windows. When typing there is a delay of about 500-1000 ms between kepress and screen. During the delay, Eclipse is not responsive. The problem goes away if I restart eclipse, but returns after I've been editing for a while. I don't have the problem with any other eclipse editors. It looked like it might be spending a lot of time updating the Outline view as I typed, however closing the Outline view doesn't make a diference.

System specs are:
Dual Xeon 3.2Ghz
2.00 GB of RAM
Xmx for Eclipse is 512 MB

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Slow text editing

Post by sorin_ristache » Fri Jan 06, 2006 11:17 am

Hello,
ChrisCrawford wrote:I'm running Oxygen on a 1.25 GHz G4 Mac under OS 10.3.9. When typing text, the CPU saturates at about 85% - 90% usage for Oxygen.
I think you have text antialiasing enabled and it does not work fast for some fonts on Mac OS. It is a problem of the Apple Java VM. Disable antialiasing in Options -> Preferences -> Editor -> Aspect or change the font in the same options panel.

Regards,
Sorin

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: Similar problems

Post by sorin_ristache » Fri Jan 06, 2006 11:52 am

Hello,
adaml wrote:I'm using Oxygen as an Eclipse plugin on Windows. When typing there is a delay of about 500-1000 ms between kepress and screen. During the delay, Eclipse is not responsive.
Please send us a sample document to support at oxygenxml dot com in order to reproduce the delay on Windows.

Regards,
Sorin

alexey
Posts: 2
Joined: Sun Jan 08, 2006 5:25 pm

Try 10.4

Post by alexey » Sun Jan 08, 2006 5:29 pm

Hello Chris,

I had the same problem, but it was several problems from the 10.3.9 update, first the
Java VM is corrupted by the update and secondly if you have a word checker or anything
running in background it delayed a lot the CPU.

Use the 10.4.x it will work great. I can edit 2000 lines document without problem, oxygen is on my machine quite fast.

Alexey

tgolden
Posts: 5
Joined: Thu Mar 09, 2006 5:45 pm

One possible solution to performance problem

Post by tgolden » Thu Mar 09, 2006 6:01 pm

I had the same miserable performance on my laptop computer - every keystroke was excrutiating. In my case, it only happened when I was on battery power. I eventually determined that a feature of my computer's graphic chip was interacting poorly with Oxygen and causing the problem.

My computer has an ATI Mobility Radeon X300. That chip has a feature called "PowerPlay", which (by default) causes the chip to switch to low-power-consumption mode when the computer is running on battery power. You can turn this power-saving feature off rather easily, and when you do, Oxygen performs as expected.

On WinXP Pro:
1. Go to Start | Control Panel | Display
2. Choose the Settings tab
3. Click the Advanced button
4. Choose the POWERPLAY tab
5. Click OFF the "Enable PowerPlay" checkbox

No other applicaiton I use has ever shown a similar behavior, and this workaround WILL reduce your battery run time, so it would be nice if the root cause could be addressed by the Oxygen folks.

robert3L
Posts: 21
Joined: Sun Jan 15, 2006 11:36 am

Post by robert3L » Mon Mar 27, 2006 3:58 pm

tgolden- thank you for this post. I did as you suggested and the horrendous sluggish performance on my laptop vanished. I was amazed.

90% of the time the workaround you suggest is fine for me, but for the 10% when I rely on battery power it's not so good.

I also hope development will investigate this! :idea: :!:

catterall
Posts: 51
Joined: Sat Jan 24, 2004 12:10 am
Location: Oaxaca, Mexico
Contact:

Post by catterall » Wed Apr 26, 2006 1:10 am

I think you have text antialiasing enabled and it does not work fast for some fonts on Mac OS. It is a problem of the Apple Java VM. Disable antialiasing in Options -> Preferences -> Editor -> Aspect or change the font in the same options panel.

Regards,
Sorin


I have 10.3.9 on a G4 (which this was in reply to) There is no Options -> Preferences -> Editor -> Aspect on this system (Oxygen 7.1 on MacOS 10.3.9. Can you make your reply applicable to the operating system please.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Post by sorin_ristache » Wed Apr 26, 2006 9:21 am

Hello,

In version 7.1 the text antialiasing configuration was moved to Options -> Preferences -> Fonts. If you use <oXygen/> on a laptop and it is slow only when the laptop is on battery you can add the following parameter to the JVM in order to make <oXygen/> to run at the normal speed:

Code: Select all

-Dsun.java2d.noddraw=true
Please see this topic for more details.

Regards,
Sorin

Post Reply