ClassCastException

This should cover W3C XML Schema, Relax NG and DTD related problems.
jmigchielsen
Posts: 2
Joined: Wed Mar 07, 2012 5:14 pm

ClassCastException

Post by jmigchielsen » Wed Mar 07, 2012 5:29 pm

I have a certain DTD, version 5.1.0. I use the catalog to find it and validate against it. The new version v5.2.0 is backwards compatible. In the catalog I copy the 5.1.0 line and change the 1s into 2s. Then I open a 5.1.0 file and change the 1s into 2s. Validation then gives this error:

SystemID: C:\Jos\test\samples\JA520\SI\00011586000000001\0169023X\v64i1\issue.xml
Main validation file: C:\Jos\test\samples\JA520\SI\00011586000000001\0169023X\v64i1\issue.xml
Engine name: Xerces
Severity: fatal
Description: ClassCastException-ro.sync.exml.n.c.v cannot be cast to ro.sync.exml.n.c.g

A colleague does the same and he does not see this error, everything works as expected. We both have oXygen 12.2.

Does this sound familiar? Can anyone solve this?

Jos Migchielsen

adrian
Posts: 2551
Joined: Tue May 17, 2005 4:01 pm

Re: ClassCastException

Post by adrian » Wed Mar 07, 2012 6:45 pm

Hello,

Please contact us on our support email address(support AT oxygenxml DOT com) and if possible send us a set of sample files(XML+DTD) that reproduce the problem.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

jmigchielsen
Posts: 2
Joined: Wed Mar 07, 2012 5:14 pm

Re: ClassCastException

Post by jmigchielsen » Thu Mar 08, 2012 12:35 pm

Hi Adrian,

Thanks for that. I found the error. I decided to do the same on another PC that had version 11.0. That version complained about IMPLIED. It turned out that I used "IMPLIED" (incl quotes) instead of #IMPLIED when I added an attribute.

It is still strange that two 12.2 versions respond differently. Any thoughts on that?

Jos

adrian
Posts: 2551
Joined: Tue May 17, 2005 4:01 pm

Re: ClassCastException

Post by adrian » Thu Mar 08, 2012 1:27 pm

Jos,

Maybe you have different options or different contexts in your files.

Can you please show me the full declaration that caused the problem?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply