Defining new entities for characters

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
burbles
Posts: 37

Defining new entities for characters

Fri Nov 05, 2010 6:25 am

I need to redefine or remap the apostrophe character in Editor and Author mode, from a 'prime' character symbol to a proper apostrophe character (&#x92;) so that the correct character appears after FO transformations. So, how can I redefine the entity character for apostrophe, or how can I add this new character (in hex code) in the entities pallette? I presume this is how I can add characters?
Thanks.
burbles
Posts: 37

Re: Defining new entities for characters

Thu Nov 11, 2010 6:31 am

Does anyone need further explanation to answer this question?
Thanks
adrian
Posts: 2477

Re: Defining new entities for characters

Thu Nov 11, 2010 6:26 pm

Hello,

If what you want is to redefine the &apos; entity then I'm afraid this isn't possible in Oxygen.

Maybe we can find some other way to obtain this. Maybe define another entity and use that instead. Or do you simply want to remap all apostrophe characters to some other character?

Not sure if the FO processor can remap characters during the PDF generation. Some investigation is required.


Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
burbles
Posts: 37

Re: Defining new entities for characters

Sat Nov 13, 2010 3:41 pm

Adrian,
I want to remap all apostrophe characters to another character. In my case, the apostrophe when typed in an XML file is a 'prime' symbol. I want this to become a proper apostrophe (i.e. the 'curly' type).
Can I add an entity for this new apostrophe in XML Editor so that it turns out correctly in an FO transformation? Are there other quick workaround solutions? Obviously I could the correct symbol from "Insert from character map", but this is a little laborious for wuick editing - are there any keyboard shortcuts that can be created for this, for example?
Many thanks
adrian
Posts: 2477

Re: Defining new entities for characters

Mon Nov 22, 2010 6:42 pm

I find this to be more of a keyboard input problem.
Are you using the correct keyboard layout for you keyboard? Or that's precisely the problem, your keyboard layout is different and has the quote(apostrophe) characters mixed up.

You can declare an entity in the XML document or in a DTD that's associated with the document but &apos; is already defined and should do the same job just as good.

e.g.

Code: Select all

I&apos;m testing an apostrophe.

In the transformation result it will end up as:

Code: Select all

I'm testing an apostrophe.


Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 1 guest