Author mode - DocBook - inserting table fails

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Author mode - DocBook - inserting table fails

Post by honyk » Thu Apr 15, 2010 10:59 am

Hello,

on one computer we are faced with the following problem if table is being inserted via toolbar into the 'para' element:

Couldn't execute operation: 'ro.sync.ecss.extensions.docbook.table.InsertTableOperation' for action: 'Insert Table' because of: class java.lang.AbstractMethodError - ro.sync.ecss.extensions.commons.table.operations.SATableCustomizerDialog.getColumnWidthsSpecifications(I)[Lro/sync/ecss/extensions/commons/table/operations/TableCustomizerConstants$ColumnWidthsType;

That document is just created using DocBook template. It cannot be reproduced on other computers. Can anybody explain the reason? Is this caused by some settings?

Author 11.2/Vista 32-bit

Regards,
Jan

Radu
Posts: 6806
Joined: Fri Jul 09, 2004 5:18 pm

Re: Author mode - DocBook - inserting table fails

Post by Radu » Thu Apr 15, 2010 11:10 am

Hi Jan,

The extension Author methods use some extension libraries which are located in the respective framework directory.
The library jar which is used by Docbook operations should be:
OXYGEN_INSTALL_DIR\frameworks\docbook\docbook.jar
In your case it is either missing, corrupted, modified or its version mismatches the version of Oxygen which uses it.
You can either un-install Oxygen making sure the jar library is removed and then re-install or you can copy it from an Oxygen installation of the same version.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Re: Author mode - DocBook - inserting table fails

Post by honyk » Tue Apr 27, 2010 2:04 pm

Thanks for that info. We have customized 'Framework' folder and it is distributed among other users. I forgot checking its content before migrating from 11.1 to 11.2. After recovering docbook.jar file everything works fine. Thanks again.

Regards,
Jan

Post Reply