Problems with Saxon

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
hilyd
Posts: 2
Joined: Wed Dec 16, 2009 12:54 pm

Problems with Saxon

Post by hilyd » Wed Dec 16, 2009 1:19 pm

Hello,

At my work, I use daily Oxygen Editor to create XML files, which are transformed into XHTML with an XSLT 1.0. When I try to run the file in order to see the HTML view, an error message appears and says:


SystemID: /Users/demonet/Desktop/Prototype_Sommaires_BVH.xsl
Nom du moteur: Saxon-PE 9.2.0.2
Gravité: warning
Description: Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor
Emplacement de début: 19:24

I don't understand why Oxygen doesn't use processor Saxon 6.5 instead of processor Saxon 9.2, both are included in 11.0 version.
Is there any problem with this version or is it configuration issue ?

Thank you for your attention and your answer and sorry for my english

LD

iulian_velea
Posts: 63
Joined: Fri Dec 12, 2003 6:34 pm
Contact:

Re: Problems with Saxon

Post by iulian_velea » Wed Dec 16, 2009 5:15 pm

Hello,

My guess is that you run a transformation scenario that uses the Saxon 9.2 transformer which is indeed an XSLT 2.0 processor.
You can take a look at the scenario by clicking on the "Configure Transformation Scenario" button from the toolbar. In the dialog that will appear the scenario associated with your file should be selected. Click on the "Edit" button and open the "Edit scenario" dialog. In this new dialog the processor is presented in the "Transformer" combo box.
If the selected processor is Saxon 9.2 you can change it to Saxon 6.5.5.

Best Regards,
Iulian.

hilyd
Posts: 2
Joined: Wed Dec 16, 2009 12:54 pm

Re: Problems with Saxon

Post by hilyd » Thu Dec 17, 2009 5:32 pm

It worked!
Thanks for your help.
Lydie

Post Reply