failed to open a 3mb xml file

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Radu3000
Posts: 11
Joined: Mon Jul 30, 2007 6:19 pm
Location: Charlotte, NC USA

failed to open a 3mb xml file

Post by Radu3000 » Tue Oct 14, 2008 4:01 pm

When I try to open a 3mb xml I see the progress bar going to the end - but the file never gets displayed.

The only time I saw this file displayed in oxygen - it was after waiting for more than 20 mins for the debug perspective to come up... and then it was not usable - couldn't get xpath executed against it.

My eval experies today...

Thanks,
Radu.

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: failed to open a 3mb xml file

Post by sorin_ristache » Tue Oct 14, 2008 4:40 pm

Hello,

Usually a file of that size is opened after such a long time if all the file content is on a single line or the file contains a very long line (tens of thousands of characters on a single line). You should enable the option Format and indent the document on open from Preferences -> Editor -> Format before opening such files in Oxygen so that it is pretty printed before the open operation.

If the lines of your XML file are not so long please send us the file for reproducing the problem.

Please contact us at support@oxygenxml.com if you need an extension for your trial period.


Regards,
Sorin

Radu3000
Posts: 11
Joined: Mon Jul 30, 2007 6:19 pm
Location: Charlotte, NC USA

Re: failed to open a 3mb xml file

Post by Radu3000 » Tue Oct 14, 2008 7:20 pm

Nope - I already have "Format and indent the document on open" checked - it still does not open.

Lines - they may very well be long - I have sent my xml to support.

Thanks,
Radu.

adrian
Posts: 2543
Joined: Tue May 17, 2005 4:01 pm

Re: failed to open a 3mb xml file

Post by adrian » Wed Oct 15, 2008 11:56 am

Hi,

In this particular case the problem was an excessive number of namespace declarations (almost one per element in the document) that amounted to 25k different prefixes for the same uri.
The learn structure feature seems to have a problem with this amount of
declarations. We will investigate and fix this in a future version.

The workaround for the problem is to disable 'Learn on open document'
from Options -> Preferences -> Editor / Content Completion.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Re: failed to open a 3mb xml file

Post by sorin_ristache » Wed Jun 03, 2009 3:26 pm

Hello,
adrian wrote:The learn structure feature seems to have a problem with this amount of
declarations. We will investigate and fix this in a future version.
We fixed the problem so that the workaround is not necessary anymore. The fix will be available in version 10.3.


Regards,
Sorin

Post Reply