oXygen CSS editor settings: do nor reformat

<oXygen/> general issues.
rvw
Posts: 2
Joined: Thu Aug 23, 2007 2:16 pm

oXygen CSS editor settings: do nor reformat

Post by rvw » Thu Aug 23, 2007 2:27 pm

I don't want oXygen to reformat my CSS code. Now, when I open a CSS file, I see that the file has another style than I'm used to. How can I disable this "feature"?

My edit style is like this:

Code: Select all


div.footer { background: grey; font-weight: bold; padding: 10px; }
oXygen makes that into this:

Code: Select all


div.footer { 
background: grey;
font-weight: bold;
padding: 10px;
}
So that five lines instead of one. I really don't like that. I've tried to edit the CSS format preferences, but that didn't help:
Options > Preferences >> Editor > Format > CSS >> uncheck all boxes

What other options do I have? Or should I go back to my old editor?

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Post by sorin_ristache » Thu Aug 23, 2007 4:22 pm

Hello,

Please uncheck the option Format and indent the document on open from Options -> Preferences -> Editor -> Format -> XML and reopen the CSS file in oXygen. This option should not have an effect on CSS files but only on XML ones. We will fix the problem in the next version of oXygen.


Thank you for the report,
Sorin

rvw
Posts: 2
Joined: Thu Aug 23, 2007 2:16 pm

Post by rvw » Thu Aug 23, 2007 4:27 pm

That fixed it! Thank you!

Post Reply