DITA-OT Transformation failed.

leah
Posts: 3
Joined: Mon Mar 29, 2021 6:09 pm

DITA-OT Transformation failed.

Post by leah » Mon Mar 29, 2021 6:17 pm

Hi all,

I am receiving an error message when trying to output a pdf using our own plugins. These plugins worked without problems in version 22, but having upgraded to Oxygen version 23 they are no longer working.

The error messages received:

1) Transformation failed. Target "epub.init" does not exist in the project "DOST". It is used from target "dita2cii.epub.do".

2) Target "epub.init" does not exist in the project "DOST". It is used from target "dita2cii.epub.do".

Any ideas on where I can start to resolve this?

Thanks!

Radu
Posts: 7528
Joined: Fri Jul 09, 2004 5:18 pm

Re: DITA-OT Transformation failed.

Post by Radu » Tue Mar 30, 2021 9:32 am

Hi,

One of your plugins seems to contribute an EPUB publishing transtype named "cii.epub.do".
Is the target "epub.init" defined in one of your custom plugin's build files?
When you run the DITA OT integrator to integrate your plugin does the integration process report any error?
Is your custom EPUB publishing plugin using targets from the "org.dita4publishers.epub" bundled with Oxygen's DITA OT or is it a totally independent plugin?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

leah
Posts: 3
Joined: Mon Mar 29, 2021 6:09 pm

Re: DITA-OT Transformation failed.

Post by leah » Wed Mar 31, 2021 12:39 pm

Hi Radu,

1) Is the target "epub.init" defined in one of your custom plugin's build files?
- I think so - how can I check this?

2) When you run the DITA OT integrator to integrate your plugin does the integration process report any error?
- Integration is successful

3) Is your custom EPUB publishing plugin using targets from the "org.dita4publishers.epub" bundled with Oxygen's DITA OT or is it a totally independent plugin?
- It is an independant plugin that was developed for us.

This error message is being displayed when I try and output both a pdf and an epub (we use AH Formatter for the pdf)

Radu
Posts: 7528
Joined: Fri Jul 09, 2004 5:18 pm

Re: DITA-OT Transformation failed.

Post by Radu » Wed Mar 31, 2021 12:58 pm

Hi,

Maybe you can use Oxygen's Find/Replace in Files utility to search in your plugin's files if the "epub.init" target exists or not.
If it does not, maybe you need to include an extra plugin which you might have forgotten to copy to the DITA OT plugins folder.
If all else fails and you provide us with the plugin contents and details about how to install and use it (support@oxygenxml.com) we can try to reproduce and investigate the problem on our side.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

leah
Posts: 3
Joined: Mon Mar 29, 2021 6:09 pm

Re: DITA-OT Transformation failed.

Post by leah » Wed Apr 07, 2021 11:14 am

Hi Radu,

Thanks for the support. I have managed to get a new error message now... Any ideas on how to go about solving this one?

Transformation failed. C:\Program Files\Oxygen XML Editor 23\frameworks\dita\DITA-OT3.x\plugins\com.oxygenxml.pdf.css\build.xml:123: Unable to create javax script engine for javascript
The following error occurred while executing this line:
The following error occurred while executing this line:
Unable to create javax script engine for javascript

Java 15 has removed Nashorn, you must provide an engine for running JavaScript yourself. GraalVM JavaScript currently is the preferred option.

BUILD FAILED
C:\Program Files\Oxygen XML Editor 23\frameworks\dita\DITA-OT3.x\build.xml:19: The following error occurred while executing this line:
C:\Program Files\Oxygen XML Editor 23\frameworks\dita\DITA-OT3.x\plugins\org.dita.base\build.xml:121: The following error occurred while executing this line:
C:\Program Files\Oxygen XML Editor 23\frameworks\dita\DITA-OT3.x\plugins\com.oxygenxml.pdf.css\build.xml:123: Unable to create javax script engine for javascript

Thanks,
Leah

Radu
Posts: 7528
Joined: Fri Jul 09, 2004 5:18 pm

Re: DITA-OT Transformation failed.

Post by Radu » Wed Apr 07, 2021 12:22 pm

Hi Leah,

Did you upgrade to Oxygen 23.0 or 23.1? You can find this out in the Oxygen main menu Help->About dialog.
I would recommend you upgrade to Oxygen 23.1.
When you download Oxygen 23.1 from our web site:
https://www.oxygenxml.com/xml_editor/do ... os=Windows

there are two installation kits, one with Java 8 (Windows 64-bit (Includes Java SE 8u202) and one with Java 15 (Windows 64-bit (Includes OpenJDK* 15.0.1)). I think right now you have an Oxygen installation with Java 15 which has trouble interpreting some Javascript when publishing because Java 15 removed a Javascript engine. I think this problem was fixed in Oxygen 23.1 but as a precaution you should get the kit with Java 8 instead.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply