Unable to install on Dell XPS13

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Hyperion
Posts: 2
Joined: Tue Aug 04, 2020 1:58 pm

Unable to install on Dell XPS13

Post by Hyperion » Tue Aug 04, 2020 2:34 pm

Hi, I am unable to install Oxygen 22.1 XML Editor (2020072902) on my brand new Dell XPS 13 9300 (Windows 10 Pro). After two third of the progress bar the installers stops suddenly without further notice. It seems to me that the installer has a problem with spaces in user names (for example: Hans Dampf) or with german umlauts (Hans Dämpf), I have both, because I tried it with a new account without umlauts and spaces (hansdampf) and there it worked. Unfortunately my files are all stored under the other account name ... . Perhaps it would be nice, to give some hints about this particular problem during the installation process.

adrian
Posts: 2676
Joined: Tue May 17, 2005 4:01 pm

Re: Unable to install on Dell XPS13

Post by adrian » Tue Aug 04, 2020 3:23 pm

Hello,

We weren't aware of such an issue with the installer. Java has some issues with exclamations marks in paths, but spaces and umlauts should not be an issue in paths. Is this the first time you install Oxygen on this system?

Could you please run the installer from a command prompt window with the argument /create-i4j-log?
e.g.

Code: Select all

oxygen-64bit.exe /create-i4j-log
This argument notifies you where the installer log file is created and opens an Explorer window there. Go through the motions with installing it in the troublesome location. Send us (to support@oxygenxml.com) the indicated i4j_nlog_* file.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Hyperion
Posts: 2
Joined: Tue Aug 04, 2020 1:58 pm

Re: Unable to install on Dell XPS13

Post by Hyperion » Tue Aug 04, 2020 4:22 pm

Thank you. Yes it was a new system, almost unused.
Now oXygen is working. I changed my Useraccount-name and changed via regedit the folder names for the account, deleted all umlauts and spaces, and it installed oXygen succesfully. (Okay, killed some other, minor things, which seemed to use absolute paths ...) I think I have an older logfile, if you are interested.

adrian
Posts: 2676
Joined: Tue May 17, 2005 4:01 pm

Re: Unable to install on Dell XPS13

Post by adrian » Tue Aug 04, 2020 4:32 pm

Yes, I am. Please send the old log file to our support email address, support@oxygenxml.com .

Regards.
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

adrian
Posts: 2676
Joined: Tue May 17, 2005 4:01 pm

Re: Unable to install on Dell XPS13

Post by adrian » Tue Aug 18, 2020 1:23 pm

Hello,

In case others encounter this issue, it appears to be this Java bug JDK-8242283 that is triggered if there are non-ASCII characters in the path and the current regional format differs from the system locale.
The issue appears when the language set for these two Windows settings is different:
  • (Settings | Time & Language | Language | Administrative language settings | Administrative tab | Language for non-Unicode programs | System locale: X)
  • (Settings | Time & Language | Regional format | Current format: Y)
The issue is fixed in Java 14.0.2 and 11.0.9. Future versions of Oxygen (v23.0 and later) will bundle versions of Java that include this bugfix.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply