Picture path error in PDF output

DmitryS
Posts: 26
Joined: Wed Nov 27, 2019 11:03 am

Picture path error in PDF output

Post by DmitryS » Fri Dec 13, 2019 2:57 pm

Hi team!
I've met a strange thing - inline images don't appear in PDF. I tried to prepare an example, but it didn't happen again for the short filepath.
Please see a screenshot.

Sincerely,
Dmitry
path_error.png
path_error.png (167.47 KiB) Viewed 537 times

Dan
Posts: 476
Joined: Mon Feb 03, 2003 10:56 am

Re: Picture path error in PDF output

Post by Dan » Mon Dec 16, 2019 3:19 pm

Can you try transforming using the classic PDF transformation, one based on XSL-FO? Do the images appear in this case? Can you move the image next to the topic, change its reference and give it a try?

Regards,
Dan

DmitryS
Posts: 26
Joined: Wed Nov 27, 2019 11:03 am

Re: Picture path error in PDF output

Post by DmitryS » Tue Dec 17, 2019 12:12 pm

Hi Dan.
I've prepared an example.
Topic from first folder is processed properly.
Topic from second folder takes error messages for every picture reference (I put the picture in two places):

Code: Select all

Image not found. URI: file:/D:/Temp/1/checkbox.svg. (See position 10:478)
Image not found. URI: file:/D:/Temp/1/../images/checkbox.svg. (See position 14:406)
Image not found. URI: file:/D:/Temp/1/../images/checkbox.svg. (See position 18:406)
Regards,
Dmitry
test.zip
(78.91 KiB) Downloaded 33 times

Dan
Posts: 476
Joined: Mon Feb 03, 2003 10:56 am

Re: Picture path error in PDF output

Post by Dan » Tue Dec 17, 2019 3:23 pm

I see that the image is outside the folder containing the transformed topic.
Please set the transformation parameter:

Code: Select all

fix.external.refs.com.oxygenxml = true
Many regards,
Dan

DmitryS
Posts: 26
Joined: Wed Nov 27, 2019 11:03 am

Re: Picture path error in PDF output

Post by DmitryS » Tue Dec 17, 2019 3:53 pm

I see, Dan, thanks!
I should have guessed that it is bad idea to transform individual topics to check the appearance of graphics.
Only ditamap.
Even if it's 40 pages.

BTW, just for ask - one of links in my example is about image inside. But is causes an error as well. Why?

Regards,
Dmitry

Dan
Posts: 476
Joined: Mon Feb 03, 2003 10:56 am

Re: Picture path error in PDF output

Post by Dan » Tue Dec 17, 2019 4:40 pm

Publishing individual topics is always more tricky because there might be references that are not processed (especially if not having a key context for it). Anyway, with fix.external.refs.com.oxygenxml parameter it should work for simple cases.
The other problem you noticed, the direct link to an image next to the topic itself, is a bug. It is also fixed by setting that parameter. We have recorded an issue about this.

Many regards,
Dan

Post Reply