"Image not found" error on PDF transformation

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Posts: 92
Joined: Fri Oct 19, 2018 2:19 am

"Image not found" error on PDF transformation

Post by Carl » Sat Nov 30, 2019 3:19 am

I have discovered a curious glitch: when I PDF my entire project (from the DITA Maps Manager), the output contains all my images, as expected. But when I PDF individual topics, sometimes the image appears, other times it is excluded! When excluded, I get errors like this:

Code: Select all

System ID: /home/clum/repos/docs-cust/PHEMI_Central/derived_data/derived_metrics_metadata_tab.dita
Scenario: DITA Map PDF - based on XSL-FO - Copy
Input file: /home/clum/repos/docs-cust/PHEMI_Central/derived_data/derived_metrics_metadata_tab.dita
Engine name: FOP
Severity: error
Description: Image not found. URI: file:/tmp/OxygenXMLTemp-clum/ditaTemporaryOutputDir-1575072427073/t1/t2/t3/t4/oxy_ex-1/_images/derived_data/columnar_high_level_overview.png. (See position 16:590)
Why are these images "not found"? They are in the same directory as other images that are "found". And why are they present when I PDF the entire manual, but skipped when I PDF a single topic?

I have tried removing my "OxygenXMLTemp-clum" directory and letting Oxygen recreate it. I also did a full PDF and verified that the topic shows my graphics. But when I tried PDF'ing that single topic again, the image is missing and I get the "image not found" error.

Posts: 7202
Joined: Fri Jul 09, 2004 5:18 pm

Re: "Image not found" error on PDF transformation

Post by Radu » Tue Dec 03, 2019 3:37 pm

Hi Carl,

Sorry but I do not have enough information to know the cause.
If you can come up with a small sample DITA project in which this problem can be reproduced, please send it to us (support@oxygenxml.com) along with detailed steps about how to reproduce the problem on our side.

Radu Coravu
<oXygen/> XML Editor

Post Reply