Issues using Database Explorer with eXist

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
ja2humph
Posts: 13
Joined: Wed Nov 22, 2006 4:45 pm

Issues using Database Explorer with eXist

Post by ja2humph » Wed Nov 22, 2006 4:57 pm

Hi

I've recently started using oXygen 8 with eXist 1.0 and have encountered a couple of issues using the database explorer:

1) Resources within collections are not displayed alphabetically by filename in the tree. For instance, I have a (very) large collection of .xql files in one collection and the order they are shown in seems to be totally random, and so I have to visually scan down the entire list to find the file I'm looking for. Is there anyway I can improve the situation?

2) When adding an .xql file as a new resource, it is then treated as a binary file - i.e. my browser tries to download the file rather than process the XQuery. If I upload the exact same file using the eXist Java client it works perfectly. Any ideas?

Thanks in advance
Julian

ja2humph
Posts: 13
Joined: Wed Nov 22, 2006 4:45 pm

Post by ja2humph » Thu Nov 23, 2006 5:38 pm

I take it these are known issues then?

Just to clarify with the 2nd problem - I can edit and save existing .xql files in the database no problem at all. It's just when I try to add one as a new resource.

stefan
Posts: 45
Joined: Wed Jan 08, 2003 9:43 am
Contact:

Post by stefan » Fri Nov 24, 2006 4:38 pm

1) You are right, it is better to display the resources sorted by name.
2) We detected the problem and a fix will be available soon.

Stefan Vasile
http://www.oxygenxml.com

ja2humph
Posts: 13
Joined: Wed Nov 22, 2006 4:45 pm

Post by ja2humph » Fri Nov 24, 2006 4:43 pm

Thanks for your reply stefan.

Just to clarify - will the fix also allow me to sort resources alphabetically then, or is it just attending to the 2nd problem?

sorin_ristache
Posts: 4144
Joined: Fri Mar 28, 2003 2:12 pm

Post by sorin_ristache » Tue Nov 28, 2006 11:21 am

Hello,

The latest build available on the Download page (2006112715) fixes the second problem. Now when you save an XQuery file in an eXist container it is saved correctly as an XQuery resource. The problem of sorting the resources alphabetically will be fixed in a future version.


Regards,
Sorin

ja2humph
Posts: 13
Joined: Wed Nov 22, 2006 4:45 pm

Post by ja2humph » Tue Nov 28, 2006 12:04 pm

Thanks Sorin - I've tried it and it works perfectly now.

I'll look forward to the alphabetical sorting fix, as this will save me an awful lot of time.

Thanks again

Post Reply