Custom XML Framework and Web Author

Post here questions and problems related to oXygen frameworks/document types.
c-e
Posts: 2
Joined: Mon May 20, 2019 4:37 pm

Custom XML Framework and Web Author

Post by c-e » Mon May 20, 2019 4:50 pm

Hello,

I created a simple new Framework (no Extension) for a custom XML. The Framework-Detection and automatic choose within "XML Author 21" works perfect and as expected. I uploaded the framework now (ZIP file with the framework folder as root entry) to the "XML Web Author 21". After opening the same file I see only the message "Cannot load associated css files".

Is there any way to debug this behavior? How can I tell which framework was chosen?

Thanks a lot.

Regards,
ce

mihaela
Posts: 205
Joined: Wed May 20, 2009 2:40 pm

Re: Custom XML Framework and Web Author

Post by mihaela » Tue May 21, 2019 12:39 pm

Hi,

After uploading a framework is necessary to restart the Web Author. Did you restarted the server?

To check the document type associated with the current document you have to use the "Report Problem" [1] action from "More" drop-down menu. In the dialog that is opened you can see the document type information in the "General info" tab, "Application Details" table, "Document Type" row.
Also, you can see all the frameworks used by Web Author in "Frameworks" tab.

For more debugging on this problem you can enable the logging for DocumentTypeDetector class [2] by adding the folloing line in the configuration file:

Code: Select all

log4j.category.ro.sync.exml.editor.DocumentTypeDetector=debug

You can send the log file on our support email address (support@oxygenxml.com) and we will analize it.

[1] https://www.oxygenxml.com/doc/ug-webaut ... rt-problem
[2] https://www.oxygenxml.com/doc/ug-webaut ... hl=logging


Best Regards,
Mihaela
Mihaela Calotescu
http://www.oxygenxml.com

c-e
Posts: 2
Joined: Mon May 20, 2019 4:37 pm

Re: Custom XML Framework and Web Author

Post by c-e » Wed May 22, 2019 11:05 am

Hi Mihaela,

thanks for your hints. After setting the Logs do DEBUG level I was able to see the detection behavior. But there is the next question:

The log is like this:

Code: Select all

2019-05-21 16:11:37,956 20807970 DEBUG [ validation-3 ] ro.sync.exml.editor.bc - Detected header: <?xml version="1.0" encoding="utf-8"?>
<?xml-stylesheet href='../../rules/ruleset.xsl' type='text/xsl'?>
<!DOCTYPE Chapter PUBLIC "-//Custom Software//DTD Test v1.0 //DE"
2019-05-21 16:11:37,957 20807971 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected DTDs: null
2019-05-21 16:11:37,959 20807973 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected XSDs after analize schemaLocation attribute: null
2019-05-21 16:11:37,959 20807973 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected XSDs after analize xml-model PIs: null
2019-05-21 16:11:37,959 20807973 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected RNG: null
2019-05-21 16:11:37,959 20807973 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected RNC: null
2019-05-21 16:11:37,960 20807974 DEBUG [ validation-3 ] ro.sync.exml.editor.xd - Detected NVDL: null
2019-05-21 16:11:37,960 20807974 DEBUG [ validation-3 ] ro.sync.exml.editor.DocumentTypeRepository - Trying to find a matching framework for:
namespace: null
root: null
system ID: http://localhost:3239/api/file/jst.<URL_REDACTED>Overview.xml
public ID: null
2019-05-21 16:11:37,960 20807974 DEBUG [ validation-3 ] ro.sync.exml.editor.DocumentTypeRepository - Root attributes:
2019-05-21 16:11:37,959 20807973 DEBUG ...
I did not cut any lines (besides the long URL in "system ID"). The XML Author detects it correct. Here is no root element detection and no public ID detection.

I tried different DocType-Elements with different errors but with no positive result. Here are they:
  • <!DOCTYPE Chapter PUBLIC "-//Custom Software//DTD Test v1.0 //DE">
  • <!DOCTYPE Chapter PUBLIC "-//Custom Software//DTD Test v1.0 //DE" "">
  • <!DOCTYPE Chapter PUBLIC "-//Custom Software//DTD Test v1.0 //DE" "../../rules.dtd">
The last one doesnt work because the DTD referred relatively doesnt exists for the Web Author but I did not found a option to prevent the Web Author from loading the DTD. It just stops working with a "Resource not found" message. This DTD is embedded in the Framework and there should be no need to load this.

Regards,
ce

mihaela
Posts: 205
Joined: Wed May 20, 2009 2:40 pm

Re: Custom XML Framework and Web Author

Post by mihaela » Wed May 22, 2019 5:22 pm

Hi,

The "Detected header" text from the log file should also contain the entire Doctype declaration and the root element. Can you please send us a sample file (on our support email adddress: support@oxygenxml.com) to be able to reproduce this problem?

Best regards,
Mihaela
Mihaela Calotescu
http://www.oxygenxml.com

Post Reply