Showing @mixed="true" in Design Mode

<oXygen/> general issues.
EarlMorton
Posts: 17
Joined: Wed Jan 11, 2017 11:27 pm

Showing @mixed="true" in Design Mode

Post by EarlMorton » Wed Feb 27, 2019 10:51 pm

In Schema Design mode, elements with anonymous types do not indicate in the diagram if @mixed="true", even when in the options, Editor > Edit Modes > Schema Design > Properties > Complex Type > Mixed is selected. Is this by design, and if so, what is the rationale for it? (For named types, the diagram indicates if they are mixed.)

As it is, I have to remind myself to switch to Text mode to see if @mixed="true". I would expect it to indicate that on the diagram.

I am using <oXygen/> XML Editor 20.1, build 2018101517.

Thanks!

Earl Morton

adrian
Posts: 2580
Joined: Tue May 17, 2005 4:01 pm

Re: Showing @mixed="true" in Design Mode

Post by adrian » Mon Mar 04, 2019 1:52 pm

Hello,

The options you mentioned only apply to an actual complex type "component" that is shown in the diagram (named complex type).
Anonymous complex types have no visual representation (no component) in the diagram from Design mode. However, Mixed=true is visible if you click on the element in the diagram and check in the Attributes view, Type > Mixed.

I cannot offer an explanation why it is this way. I've submitted an issue to investigate if this is an oversight.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

EarlMorton
Posts: 17
Joined: Wed Jan 11, 2017 11:27 pm

Re: Showing @mixed="true" in Design Mode

Post by EarlMorton » Wed Mar 06, 2019 8:30 pm

OK, thanks Adrian!

Post Reply