Xinclude 1.1 Validation error

Questions about XML that are not covered by the other forums should go here.
mabecher
Posts: 1
Joined: Fri Jan 19, 2018 6:05 pm

Xinclude 1.1 Validation error

Post by mabecher » Fri Jan 19, 2018 6:28 pm

Hi,

in the new version of the DTD for xinclude the attribute parse has the default value "application/xml".

I include a DTD module with this line (<!ATTLIST ... parse CDATA "application/xml"),
choose the version 1.1 of include in the oxygen preferences,
I don't set the attribute in my xml file, so the default value must be used.

but always get a parse error:
"Invalid value for 'parse' attribute on 'include' element: 'application/xml'."

If I use <!ATTLIST ... parse CDATA "xml"), anything is right, but this is not conform to
https://www.w3.org/TR/xinclude-11/ , section 3.1.


Any idea?
Thanks Margit

Radu
Posts: 6590
Joined: Fri Jul 09, 2004 5:18 pm

Re: Xinclude 1.1 Validation error

Post by Radu » Mon Jan 22, 2018 10:26 am

Hello Margit,

I found these explanations in the XInclude 1.1 specs:
With two exceptions, the value of the parse attribute must conform to the requirements of a media type, see [IETF RFC 4288]. The exceptions are “xml” which must be treated as “application/xml” and “text”, which must be treated as “text/plain”.

This attribute is optional. When omitted, the value of “application/xml” is implied.
So if you omit @parse completely, then it's application/xml parse. If you set parse="xml", it's equivalent to parse="application/xml".
But indeed the validation should also recognize application/xml parse and this is something we need to solve on our side.
When validating xi:Includes the DTDs are not used at all because xi:includes are validated and expanded before the DTDs are used to validate the XML document (as xi:includes are transparent) so we need to modify the actual engines which perform the validation.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Radu
Posts: 6590
Joined: Fri Jul 09, 2004 5:18 pm

Re: Xinclude 1.1 Validation error

Post by Radu » Mon Mar 19, 2018 1:13 pm

Hi,

Oxygen XML Editor version 20 which we just released should have a fix for this problem:
But indeed the validation should also recognize application/xml parse and this is something we need to solve on our side.
Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply