Insert row bug

dcramer
Posts: 154
Joined: Sat Aug 28, 2010 1:23 am

Insert row bug

Post by dcramer » Tue Jan 16, 2018 6:44 pm

We've run across a strange bug using the insert row actions when a document has two prefaces and the first one is xincluded in.

I've put example files and a screen cap of the error dialog up in a gist:

https://gist.github.com/dwcramer/f29bfd ... 88e28a2743
  1. Save doc.xml and preface1.xml on your file system.
  2. Open doc.xml in Oxygen.
  3. Put the cursor in an entry in the table.
  4. Invoke an insert table row action (insert.table.row.above, insert.table.row.below, insert.table.rows.custom) using a toolbar button or the DocBook5->Table menu).
Expected behavior: A row or rows are inserted.
Actual behavior: The Error dialog shown in Oxygen-Error-Dialog.png appears.

We've reproduced this in 18.1 and 19.1.

Regards,
David

alex_jitianu
Posts: 699
Joined: Wed Nov 16, 2005 11:11 am

Re: Insert row bug

Post by alex_jitianu » Wed Jan 17, 2018 4:40 pm

Hello,

Thank you for reporting this issue. I managed to reproduced it myself and I added an issue to further investigate the cause. As soon as we release a fix, we will send you a notification.

Best regards,
Alex

sorin_carbunaru
Site Admin
Posts: 248
Joined: Mon May 09, 2016 9:37 am

Re: Insert row bug

Post by sorin_carbunaru » Mon Mar 19, 2018 6:05 pm

Hello,

This issue has been addressed in version 20 of oXygen, which has been recently released.

Thank you for the feedback!

All the best wishes,
Sorin Carbunaru
oXygen XML

dcramer
Posts: 154
Joined: Sat Aug 28, 2010 1:23 am

Re: Insert row bug

Post by dcramer » Mon Mar 19, 2018 6:25 pm

Thanks for the update!

A quick test confirms the bug is no longer manifesting itself in my test docs.

Regards,
David

Post Reply