v7 - syntax coloring

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Franck
Posts: 35
Joined: Fri Jun 03, 2005 11:00 am

v7 - syntax coloring

Post by Franck » Mon Jan 16, 2006 1:22 pm

minor problem with the syntax coloring . If I associate a specific color to my XSL namespace, the closing > of the opening tag is in the wrong color.

<xsl:value-of select="//DocumentType"/>

and

<xsl:value-of select="//DocumentType"></xsl:value-of>

About syntax coloring, I would personally prefer the option of simply coloring the prefix in a separate color.

Radu
Posts: 7019
Joined: Fri Jul 09, 2004 5:18 pm

Post by Radu » Mon Jan 16, 2006 4:11 pm

Hi Franck,

Your observations are correct.
But trying to color the ">" in the same color as the start tag name would imply additional processing which could lead to performance problems (repaints are done very often) which we think are not justified by such a minor issue...

About coloring only the prefix with another color, a bug entry was placed so the issue will be discussed and you will be notified as soon as we come to a conclusion.

Thanks for the input.
Regards, Radu

Mircea
Posts: 76
Joined: Tue Mar 25, 2003 11:21 am

Re: v7 - syntax coloring

Post by Mircea » Thu Feb 02, 2006 4:42 pm

Hi Franck,

The issue with the syntax coloring of the prefixed elements was resolved and will be available in the next release.
There is an option in preferences that will allow you to choose if you want only the prefix to be painted in other color than the usual tag.

It will look like:
<xsl:value-of select="//DocumentType"></xsl:value-of>

Best regards,
Mircea

Franck
Posts: 35
Joined: Fri Jun 03, 2005 11:00 am

Thanks

Post by Franck » Thu Feb 02, 2006 4:47 pm

You guys are real quick!

I wish my parents had been as attentive to my every needs... ;-P

Cheers

Post Reply