Bug: Webhelp 19 exact phrase search

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
caval
Posts: 25

Bug: Webhelp 19 exact phrase search

Wed Apr 12, 2017 6:48 pm

Let me begin by expressing my congratulations for webhelp 19! The new search features are a huge improvement and make the webhelp much more usable and modern.

However, I did notice an issue with exact phrase searches. If a term contains punctuation, no results are returned. For example: "index.html". I also had the same issue when searching for a sentence containing a comma.

Can this be fixed so that punctuation is either included or ignored?
radu_pisoi
Posts: 302
Location: Craiova

Re: Bug: Webhelp 19 exact phrase search

Thu Apr 13, 2017 3:06 pm

Hi,

Thank you for reporting this problem.

I can reproduce your problem only when there is a space in front of the punctuation character.

For instance, the "index.html" search query returns expected results, see:
https://www.oxygenxml.com/doc/versions/ ... ex.html%22

The problem can be reproduced with next search query: "When selected, Oxygen"
https://www.oxygenxml.com/doc/versions/ ... +Oxygen%22

I will register this problem on our issue tracking system. I think we'll fix it in the next maintenance build.
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
radu_pisoi
Posts: 302
Location: Craiova

Re: Bug: Webhelp 19 exact phrase search

Tue Oct 03, 2017 8:11 am

Hi,

This issue was fixed in oXygen WebHelp 19.1.
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 2 guests