Installing Web Author

ann.jensen
Posts: 194

Installing Web Author

Thu Jan 05, 2017 3:20 pm

Hi,
I am trying to configure Oxygen XML Web Author on my machine in order to test its use with a sample DITA repository.
I have installed it from https://www.oxygenxml.com/xml_web_autho ... uthor.html to C:\Program Files\oXygen XML Web Author 18.0. I have started the Tomcat instance and started the Oxygen XML Web Author server. I can access the main page at http://localhost:9999/oxygen-xml-web-au ... xygen.html but cannot access the Administration page.
I have the following in C:\Program Files\oXygen XML Web Author 18.0\tomcat\conf\tomcat-users.xml

Code: Select all

<tomcat-users xmlns="http://tomcat.apache.org/xml"
              xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              xsi:schemaLocation="http://tomcat.apache.org/xml tomcat-users.xsd"
              version="1.0">
<!--
  NOTE:  By default, no user is included in the "manager-gui" role required
  to operate the "/manager/html" web application.  If you wish to use this app,
  you must define such a user - the username and password are arbitrary. It is
  strongly recommended that you do NOT use one of the users in the commented out
  section below since they are intended for use with the examples web
  application.
-->
<!--
  NOTE:  The sample user and role entries below are intended for use with the
  examples web application. They are wrapped in a comment and thus are ignored
  when reading this file. If you wish to configure these users for use with the
  examples web application, do not forget to remove the <!.. ..> that surrounds
  them. You will also need to set the passwords to something appropriate.
-->
  <role rolename="admin"/>
  <user username="tralee\ajensen" password="password" roles="admin"/>
  <role rolename="user"/>
  <user username="webapp" password="0ff2b567a5859b5a4572cbda6ecdee19491a89ea3589bb66c3a3d80e72c1ca80" roles="user"/>
</tomcat-users>


When I select the Administration Page link I am prompted to enter credentials in a Windows Security popup. I entered the details for the admin user but it doesn't succeed.
Any advice appreciated,
Regards,
Ann
cristi_talau
Posts: 123

Re: Installing Web Author

Thu Jan 05, 2017 5:24 pm

Hello,

Can you try changing the user name to include only ASCII characters. E.g. instead of

Code: Select all

<user username="tralee\ajensen" password="password" roles="admin"/>


use

Code: Select all

<user username="traleeajensen" password="password" roles="admin"/>


When you go to the Admin Page, the popup window is a browser-specific authentication form, so you need to enter the user and password configured for Tomcat, not your Windows credentials. We are going to improve this in the next version when we'll use a HTML form for logging in.

Best,
Cristian
ann.jensen
Posts: 194

Re: Installing Web Author

Thu Jan 05, 2017 5:26 pm

Hi,
I did actually try that already this morning and still no luck.
Thanks,
Ann
cristi_talau
Posts: 123

Re: Installing Web Author

Thu Jan 05, 2017 5:36 pm

Hello,

Just to rule out other problems with your installation: try to replace in C:\Program Files\oXygen XML Web Author 18.0\tomcat\conf\tomcat-users.xml both the username and passwors with "admin".

Code: Select all

<tomcat-users xmlns="http://tomcat.apache.org/xml"
              xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              xsi:schemaLocation="http://tomcat.apache.org/xml tomcat-users.xsd"
              version="1.0">
  <role rolename="admin"/>
  <user username="admin" password="admin" roles="admin"/>
  <role rolename="user"/>
  <user username="webapp" password="0ff2b567a5859b5a4572cbda6ecdee19491a89ea3589bb66c3a3d80e72c1ca80" roles="user"/>
</tomcat-users>


Make sure to restart Tomcat after changing this file [1].

When the browser authentication window (that resembles the Windows Security popup) appears, type "admin" for both username and password.

Best,
Cristian

[1] https://www.oxygenxml.com/doc/versions/ ... start.html
ann.jensen
Posts: 194

Re: Installing Web Author

Thu Jan 05, 2017 6:01 pm

Hi Christian,
No, that gives same result. It might have to do with security on my laptop as it is a company one.
Thanks,
Ann
ann.jensen
Posts: 194

Re: Installing Web Author

Thu Jan 05, 2017 6:28 pm

I am seeing an error appear in the Tomcat command window that says

Code: Select all

Cannot connect to the licensing server.....

after

Code: Select all

Server startup in 8610 ms
cristi_talau
Posts: 123

Re: Installing Web Author

Wed Sep 27, 2017 11:52 am

Hello,

We investigated the issue and one of the 3rd party components that we use for authentication does not support non-ASCII characters in user-name and passwords. The workaround would be to use a password that contains only English letters, digits and punctuation signs.

Best,
Cristian

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest